Bug 541878 - X11 drawing operations very slow
X11 drawing operations very slow
Status: CLOSED DUPLICATE of bug 523646
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
: 542097 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 06:44 EST by Ralf Ertzinger
Modified: 2009-12-05 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 19:33:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of Xorg during gdm user select (1.47 MB, text/plain)
2009-11-27 07:07 EST, Ralf Ertzinger
no flags Details
xorg.conf (problem appears without xorg.conf, too) (325 bytes, text/plain)
2009-11-27 07:09 EST, Ralf Ertzinger
no flags Details
xorg.0.log (21.19 KB, application/x-gzip)
2009-11-27 07:11 EST, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2009-11-27 06:44:36 EST
Description of problem:
Video hardware: Intel Q45 integrated video

X feels very sluggish whenever actual drawing operations are taking place. top shows the Xorg process using up an entire CPU on it's own during that time. stracing shows that almost all time is spent in ioctl() calls to an open filehandle on /dev/dri/card0.

strace output and Xorg.0.log attached.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.9.1-1.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. Boot into gdm
2.
3.
  
Actual results:
Drawing the GDM login screen is very slow, as is using the dialog

Expected results:
normal, fast behaviour

Additional info:
Comment 1 Ralf Ertzinger 2009-11-27 06:58:54 EST
I just found out that almost every action in GDM (including just moving the mouse) results in new DCC probe messages appearing in /var/log/Xorg.0.log, describing the attached monitor.
Comment 2 Ralf Ertzinger 2009-11-27 07:07:09 EST
Created attachment 374204 [details]
strace of Xorg during gdm user select

The only action performed during this strace was selection of a user name in the GDM login dialog by pressing Enter. The strace was terminated when the password selection dialog had appeared completely.
Comment 3 Ralf Ertzinger 2009-11-27 07:09:58 EST
Created attachment 374205 [details]
xorg.conf (problem appears without xorg.conf, too)
Comment 4 Ralf Ertzinger 2009-11-27 07:11:30 EST
Created attachment 374206 [details]
xorg.0.log

System is F12, but runs a rawhide kernel for testing. Problem also appears with kernel-PAE-2.6.31.5-127.fc12.i686.
Comment 5 Chris Campbell 2009-11-27 17:30:49 EST
All logs aboard.

This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Need Real Name 2009-11-28 08:43:08 EST
*** Bug 542097 has been marked as a duplicate of this bug. ***
Comment 7 Michal Schmidt 2009-11-28 10:35:40 EST
The Xorg.0.log is very long with lots of repeated output of monitor detection. It's similar to https://bugzilla.redhat.com/show_bug.cgi?id=523646#c12
Comment 8 Michal Schmidt 2009-11-29 14:31:13 EST
In https://bugzilla.redhat.com/show_bug.cgi?id=523646#c16 there is a report that kernel-2.6.31.6-145.fc12.x86_64 from updates-testing improves the situation. Since these two bugs look very similar, can someone here test that kernel too?
Comment 9 Need Real Name 2009-11-29 16:45:31 EST
I only get bad performance at the login screen, and for me 2.6.31.6-145.fc12.x86_64 does not exhibit this behaviour.
Comment 10 Ralf Ertzinger 2009-11-30 02:43:17 EST
For me the problem carries over to the desktop, and 2.6.31.6-145.fc12.PAE.i686 does not fix it (neither in GDM nor on the desktop)
Comment 11 yohan.bataille 2009-12-01 01:04:31 EST
Hi,
I reported this bug here https://bugs.freedesktop.org/show_bug.cgi?id=24556 a while ago. I closed it but I should not have : 

$ ls -lh /var/log/Xorg.0.log
-rw-r--r-- 1 root root 115M nov.  30 17:12 /var/log/Xorg.0.log

The bug still occurs with kernel 2.6.31.6-145.fc12 both at GDM login screen and while using firefox.

There is a sysprof log in the bug I filed in freedesktop bugzilla.

This was my description of the bug :
"Xorg is very sluggish on my intel X4500HD graphic card.
It's sluggish even in GDM at startup but it's worse when using firefox : it's
getting slower and slower until X seems to be freezed and hard reboot is
needed.
The uncompressed Xorg log weights 15M. sysprof points to drm_do_probe_ddc_edid.
I don't have a Xorg.conf and I don't use composition."
Comment 12 yohan.bataille 2009-12-01 01:12:36 EST
Isn't this bug the same as https://bugzilla.redhat.com/show_bug.cgi?id=523646 ?
Comment 13 Ralf Ertzinger 2009-12-01 04:09:18 EST
It probably is.

I noticed something else, which may be related, running F11 (fully updated, shared home dir) on the same hardware. Soon after starting GNOME the kernel starts triggering a flood of udev events relating to the graphics card:

KERNEL[1259658330.187297] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
KERNEL[1259658330.201980] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
KERNEL[1259658330.209853] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
KERNEL[1259658330.214514] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
KERNEL[1259658330.218688] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)

This just goes on and on. The system stays usable, though, it just triggers a ton of udev child processes.
Comment 14 Matěj Cepl 2009-12-02 19:33:05 EST

*** This bug has been marked as a duplicate of bug 523646 ***
Comment 15 Need Real Name 2009-12-05 18:22:34 EST
(In reply to comment #9)
> I only get bad performance at the login screen, and for me
> 2.6.31.6-145.fc12.x86_64 does not exhibit this behaviour.  

I think I was lucky. 50% of the time I get the slow behaviour.

Note You need to log in before you can comment on or make changes to this bug.