Bug 541888 - Fontforge crashes when loading font
Summary: Fontforge crashes when loading font
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 12
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-27 13:18 UTC by Tobias Ringstrom
Modified: 2010-06-21 07:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-24 18:44:15 UTC
Type: ---


Attachments (Terms of Use)

Description Tobias Ringstrom 2009-11-27 13:18:34 UTC
Description of problem:

It seems to crash no matter which font I try to open.  New works.

> fontforge /usr/share/fonts/dejavu/DejaVuSansMono.ttf
Copyright (c) 2000-2009 by George Williams.
 Executable based on sources from 22:35 GMT 22-Jun-2009.
 Library based on sources from 22:35 GMT 22-Jun-2009.
Failed to create a fontset for the input method
-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-1,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-2,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-3,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-4,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-5,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-9,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-10,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso8859-15,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-koi8-uni,-arphic-ar pl uming cn-light-r-normal--16-0-0-0-p-0-gb2312.1980-0,-arphic-ar pl uming tw-light-r-normal--16-0-0-0-p-0-big5-0,-urw-urw gothic l-medium-r-normal--16-0-0-0-p-0-iso10646-1
Help! Server claimed font
	-arphic-ar pl uming tw-light-r-normal--13-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
Segmentation fault (core dumped)


Version-Release number of selected component (if applicable):

fontforge-20090622-2.fc12.x86_64


How reproducible:

Always.


Steps to Reproduce:
1. yum install fontforge
2. fontforge /usr/share/fonts/dejavu/DejaVuSansMono.ttf
  
Actual results:

Crash, boom, bang.  (See above)

Expected results:

Less crash, boom and bang.

Additional info:

Comment 1 Kevin Fenzi 2009-11-27 16:36:59 UTC
This looks like an issue I have seen a number of times before: Your font caches were not updated when you uninstalled/installed/upgraded fonts. So, fontforge asks what fonts are available, the X server lies to it and when it tries to use of the ones thats not really there it blows up. ;( 

Try re-running 'fc-cache' against all the directories under /usr/share/X11/fonts/ and see if that fixes it. 
Or check all the font cache files there for this font it's looking for and regenerate that one. 

See bug 450709 for more info.

Comment 2 Tobias Ringstrom 2009-12-01 13:10:43 UTC
There are no fonts in /usr/share/X11/fonts/.  Did you mean /usr/share/fonts/?

I tried removing all files in ~/.fontconfig, and I also ran 'fc-cache /usr/share/fonts/*', but fontforge still crashed.

As you can see in the error above, fontforge complains about the font -arphic-ar-something.  That font is in cjkuni-uming-fonts-0.2.20080216.1-29.fc12.noarch.  Removing that RPM makes fontforge work.

While it's possible that there's a problem with the cjkuni-uming-fonts RPM, Fontforge should still not crash.

Comment 3 Kevin Fenzi 2009-12-06 18:47:02 UTC
Strange. So I have this font installed here, and fontforge works fine. 

What do you see in: 

xlsfonts | grep "arphic-ar" | grep 13

I've talked with upstream about this before, and they won't fix it, as they say the X server should never lie to them and tell them that a font can be used when it cannot. :( 

What is your locale set to?

Comment 4 Tobias Ringstrom 2009-12-07 11:37:25 UTC
Even stranger.

I reinstalled cjkuni-uming-fonts-0.2.20080216.1-29.fc12.noarch.rpm, and fontforge works fine. The last time I tried, I could remove the package and fontforge would work, and then install it again and fontforge would crash.  I tried it a couple of times. I have updated other packages since then, and also rebooted once.  I guess it's fixed?

In case it still matters, I get nothing from "xlsfonts | grep "arphic-ar" | grep 13", and my locale is en_US.utf8.

Comment 5 Kevin Fenzi 2009-12-09 22:56:57 UTC
Strange. I didn't do anything at all... ;( 

I guess we close this as a mystery?

Comment 6 Praveen Arimbrathodiyil 2010-05-14 07:20:34 UTC
It works when cjkuni-ukai-fonts is installed. see #592178

Comment 7 Jens Petersen 2010-06-21 07:34:38 UTC
It might also have been a cjkuni packaging issue that got fixed perhaps?


Note You need to log in before you can comment on or make changes to this bug.