Bug 54190 - kupdated locks during heavy I/O to mix of ext2 and reiserfs
Summary: kupdated locks during heavy I/O to mix of ext2 and reiserfs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-01 13:28 UTC by John Dalbec
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-01 13:28:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Dalbec 2001-10-01 13:28:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
I use the exim MTA (self-compiled).  The mailbox directories are on ReiserFS/aic7xxx_mod/IBM ESS ("Shark"); the spool directory 
(contains 
the logs and the delivery journal file) is on ext2/ips/IBM ServerRAID.  When delivering a short test message to an alias that expands to 
100 
users, the delivery process goes into a 'D' wait as does kupdated.  Usually one of the lock files is left behind.

Version-Release number of selected component (if applicable):
2.4.7-10

How reproducible:
Always

Steps to Reproduce:
1. Set up /var/spool/mail on ReiserFS, leave /usr/local on ext2.
2. Install exim from tarball.
3. Create mail alias for 100 users.
4. Send short message to mail alias.
	

Actual Results:  Delivery process (exim) goes into 'D' wait, does not terminate.
kupdated goes into 'D' wait.
any process that tries to update the disk goes into 'D' wait.  This includes /sbin/shutdown.  Time to flip the power switch.

Expected Results:  Delivery should terminate normally.

Additional info:

Kernel 2.4.3-15 works fine.

Comment 1 John Dalbec 2001-10-24 13:19:11 UTC
Sorry, it looks like I was using a bad version of the ReiserFS quota patches.  I believe I have kernel-2.4.9-6 working OK with the latest patches.


Note You need to log in before you can comment on or make changes to this bug.