Bug 541947 - DeprecationWarning: object.__new__() takes no parameters and md5 module is deprecated
Summary: DeprecationWarning: object.__new__() takes no parameters and md5 module is de...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-toscawidgets
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-27 16:48 UTC by Mads Kiilerich
Modified: 2009-12-18 04:36 UTC (History)
3 users (show)

Fixed In Version: 0.9.8-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-18 04:27:25 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2009-11-27 16:48:30 UTC
Description of problem:

While trying to install an unrelated python package (http://code.google.com/p/python-graph/source/checkout):

[mk@localhost core]$ python setup.py --help-commands
/usr/lib/python2.6/site-packages/tw/core/view.py:223: DeprecationWarning: object.__new__() takes no parameters
  obj = object.__new__(cls, *args, **kw)
/usr/lib/python2.6/site-packages/tw/core/command.py:9: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Standard commands:
  build                   build everything needed to install
...


If the warning only appeared when this package actually was used then it would be ok, but now when it also appears and confuses where it shouldn't be loaded at all then I think it should be patched ASAP.


Version-Release number of selected component (if applicable):

python-toscawidgets-0.9.8-1.fc11.noarch

Comment 1 Toshio Ernie Kuratomi 2009-11-29 19:15:50 UTC
I suspect this is happening because setuptools is braindead (setuptools is used to build python-graph; toscawidgets uses setuptools for loading plugins.)

We'll look at fixing these DeprecationWarnings though.

Comment 2 Toshio Ernie Kuratomi 2009-11-29 19:48:37 UTC
I've attached a patch to upstream bug: http://toscawidgets.org/trac/tw/ticket/46

Building fixed packages now.

Comment 3 Fedora Update System 2009-11-29 20:03:46 UTC
python-toscawidgets-0.9.8-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-toscawidgets-0.9.8-2.fc11

Comment 4 Fedora Update System 2009-11-29 20:03:51 UTC
python-toscawidgets-0.9.8-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-toscawidgets-0.9.8-2.fc12

Comment 5 Fedora Update System 2009-12-01 04:23:41 UTC
python-toscawidgets-0.9.8-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-toscawidgets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12369

Comment 6 Fedora Update System 2009-12-01 04:25:37 UTC
python-toscawidgets-0.9.8-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-toscawidgets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12381

Comment 7 Mads Kiilerich 2009-12-13 14:33:13 UTC
Confirmed fixed in f12 testing. Waiting for bodhi to close this issue.

Comment 8 Fedora Update System 2009-12-18 04:27:20 UTC
python-toscawidgets-0.9.8-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-12-18 04:36:33 UTC
python-toscawidgets-0.9.8-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.