This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 54199 - modemlights_applet could not find pppon/pppoff
modemlights_applet could not find pppon/pppoff
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-applets (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 11:39 EDT by Mark Dalton
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 16:17:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Dalton 2001-10-01 11:39:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
modemlights_applet could not find the pppon/pppoff script/application.
So I changed it to ifup ppp0 and ifdown ppp0 to work around this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 7.1.94 BETA (Rosewell Release) (CD from Cheapbytes)
2.Configure dial-up connection (System-Settings -> Internet Configuration
Wizard)
3.Right click on bottom pannel and select (Applets --> Modemlights)
4.Click on the left hand side of the modemlights applet (it fails)
5.Right click on the modemlights_applet, go to properties and note
  it uses 'pppon' and 'pppoff'.  If you change it to 'ifup ppp0' and
  'ifdown ppp0', then all is well.  Or add a 'pppon' & 'pppoff'
  script.
	

Actual Results:  nothing,.. the applet fails to dialup since the
pppon/pppoff scripts are missing.

Expected Results:  Dialup connection and change to a green light, and get a
IP address
as found in /var/log/messages or via ifconfig 

Additional info:


Perhaps pppon/pppoff are just for some reason missing from my system.
I used the Installer to install (fresh install).  This was with the default
system installed.

FYI... after I got modemlights working, I did upgrade to 2.4.10 kernel
and it has been working wonderfully. (I had to patch with the ext3, it
was to use a different firewall with IPTables).
Comment 1 Havoc Pennington 2002-03-04 17:49:50 EST
 Fixed in 1.4.0.5-2

Note You need to log in before you can comment on or make changes to this bug.