Bug 542076 - NM does not work for USB modem mobile connection every time, but wvdial does
NM does not work for USB modem mobile connection every time, but wvdial does
Status: CLOSED DUPLICATE of bug 553199
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-28 03:33 EST by Rakesh Pandit
Modified: 2010-02-08 21:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-08 21:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages file (1.82 KB, application/octet-stream)
2010-01-05 08:07 EST, Rakesh Pandit
no flags Details
with ModemManager 0.2.997-5.git20100101 (76.69 KB, application/x-troff-man)
2010-01-05 08:17 EST, Rakesh Pandit
no flags Details

  None (edit)
Description Rakesh Pandit 2009-11-28 03:33:29 EST
Description of problem:
I am using USB modem mobile connection to connect to network. Some when signal is weak (I guess), NM does not connect via my device but wvdial is able to do so.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.996-6.git20091021.fc12.x86_64

How reproducible:
Occasionally (happens often enough to record in a week), in case signal is weak (which is a guess)

Steps to Reproduce:
1. Connect via NM (automatically)
2. Fails
3. Try using wvdial and it works
  
Actual results:
NM does not work everytime.

Expected results:
NM should work for every case.

Additional info:
I understand the above input is not enough to fix things and spot were things needs to get improved.

I would be pleased to give more input or test things

Thanks,
Comment 1 Dan Williams 2010-01-04 18:13:05 EST
Can you try the latest NetworkManager and ModemManager updates and tell me if that makes the situation any better?

If it doesn't, then we need to debug things more, which you can do by reproducing the problem and then attaching your /var/log/messages file to this bug report.  Thanks!
Comment 2 Rakesh Pandit 2010-01-05 08:07:36 EST
Created attachment 381750 [details]
messages file

Attached is the messages file. Updated to latest NM
NetworkManager-0.7.997-2.git20091214.fc12.x86_64

wvdial worked again.

Ping me if you want more input.

Thanks,
Comment 3 Rakesh Pandit 2010-01-05 08:10:20 EST
ModemManager is ModemManager-0.2.997-4.git20091218.fc12.x86_64
Comment 4 Rakesh Pandit 2010-01-05 08:17:49 EST
Created attachment 381754 [details]
with ModemManager 0.2.997-5.git20100101

Tried with 0.2.997-5.git20100101 in update-testing. Same result.

Attached is latest file
Comment 5 Dan Williams 2010-01-16 19:43:04 EST
What model number is the modem?  EC121 or EC168C perhaps?  Are you sure you're in an area with OK coverage?  It may also take the modem up to a minute to find the network, so you may need to wait a bit before trying to dial.
Comment 6 Dan Williams 2010-01-16 19:43:57 EST
The logs you've got say the modem failed to dial because of "no service", so I'd assume that the device just doesn't have good enough signal strength to register with the network :(
Comment 7 Dan Williams 2010-02-08 21:04:10 EST

*** This bug has been marked as a duplicate of bug 553199 ***

Note You need to log in before you can comment on or make changes to this bug.