Bug 542138 - kdm console login problem
kdm console login problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On: 470004 572199
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-28 09:34 EST by Neal Becker
Modified: 2010-10-20 13:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 13:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2009-11-28 09:34:36 EST
Description of problem:

This is about kdm.  Doesn't have a BZ entry.

choose console login.  Works fine.  But, even after exiting shell, where is X?  Tried Alt-F1.

Version-Release number of selected component (if applicable):

kdm-4.3.3-7.fc12.1.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2009-11-30 07:56:19 EST
It's a bug in upstart causing this, bug #470004

*** This bug has been marked as a duplicate of bug 470004 ***
Comment 2 Kevin Kofler 2009-11-30 18:08:38 EST
Actually, this looks more related to bug 475890 to me.
Comment 3 Kevin Kofler 2009-11-30 18:08:51 EST
Does changing /etc/kde/kdm/kdmrc as suggested in:
https://bugzilla.redhat.com/attachment.cgi?id=374909
fix your issue?
Comment 4 Neal Becker 2009-11-30 20:52:25 EST
No, that didn't seem to fix it.  After that change, I noticed vt1 was no longer X, X was on 7 IIRC.

After login to console, and then exit shell, I couldn't find the X server on any vt I tried.
Nothing very informative in /var/log/messages.
Comment 5 Rex Dieter 2009-12-01 08:08:25 EST
It really is the the upstart bug here.
Comment 6 Rex Dieter 2010-10-20 13:28:41 EDT
ok, upststart is fixed and so is this, for the most part (for me using f13/kde-4.5.2),

Minor problem remains:
* Console login tries vt1, which is empty (is what X normally uses)
(I'm not going to worry too much about this atm, probably requires more plymouth-related love/config)

Switching to v2 (or 3 or 4 or whatever), can login, logout, then X starts back up in ~10 seconds.
Comment 7 Rex Dieter 2010-10-20 13:30:59 EDT
ok,  dropping tty1 from 
ConsoleTTYs=
in kdmrc makes the cosmetic issue go away, though I'm not scared of other side-effects.  I'll test more.
Comment 8 Rex Dieter 2010-10-20 13:45:50 EDT
s/not/now/ :)

Note You need to log in before you can comment on or make changes to this bug.