Bug 54233 - Memory Leak, High RAM Usage
Memory Leak, High RAM Usage
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 23:15 EDT by Nick H
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 09:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick H 2001-10-01 23:15:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
There seems to be a memory leak problem with Bind/Named ver 9.1.0 under 
RedHat 7.1. My pc is a p3 500 with 96 megs of ram. Named is running as a 
DNS caching server on my gateway for the local lan.

It has two 10/100 mbit network cards 1 connected to oputs@home and the 
other the local lan. 

After a fresh boot my gateway uses upto 34-36 megs of RAM, after named has 
been running for awhile all 96 megs is being used and so is part of the 
128 meg swap... (but only upto 3 megs of the swap if that.)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run named as a DNS caching server.
2.use it for > 12 hours 
3.top and look at RAM usage :P~
	

Actual Results:  RAM is totaly used up unnecessarly, top only says that 
named is using upto 20 megs or so, but another 40 - 60 megs goes missing 
somewhere.

 

Additional info:

Even if i kill or stop named and reload all the RAM still doesnt come 
back, have to reboot to get RAM back.
Comment 1 Michael Schwendt 2001-10-02 09:02:26 EDT
Instead of misinterpreting the output of "top", better have a look at the second
output line of "free", or run "xosview", and observe how much of your otherwise
unused RAM is used for buffers and cache *temporarily*. And that swap space is
used although the system is not short on memory has been the nature of the 2.4
kernels so far.
Comment 2 Bernhard Rosenkraenzer 2001-10-24 07:30:04 EDT
I agree with mschwendt@web.de's comment - chances are you are misinterpreting 
the numbers, especially considering that named passed all our tests and the 
named running on bero.org (primary for 93 domains, secondary for 16 others) is 
using up just 4 MB RAM after 214 days of uptime.

Note You need to log in before you can comment on or make changes to this bug.