Bug 54236 - (ISAPNP IRQ ASSIGN) mouse halt console and X when CS4232 sound-card is installed.
(ISAPNP IRQ ASSIGN) mouse halt console and X when CS4232 sound-card is instal...
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-02 04:40 EDT by Mario Minutolo
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-05 15:30:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mario Minutolo 2001-10-02 04:40:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After installin RH 7.1 on a PC with Crystal Audio sound card the mouse 
stop working. X hangs. Console hangs as soon as you move the mouse.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install RH 7.1 with sound configuration on a PC with a CS4232.
2.Restart the PC in Graphic mode to have non mouse and keyboard input 
2b.Restart in console mode.
3b.Move the mouse to have no mouse and keyboard input allowed.

Actual Results:  I tried to work around that problem. First I stopped gpm 
so that moving the mouse will not cause system stop responding. Then I 
tried to configure mouse again. Tring to configure mouse I found errors on 
mouseconfig, which keeps adding a DEVICE=/dev/mouse to its script without 
beeing able to interpret it.

Expected Results:  I should have been able to cnfigure my 

Additional info:

I have decided to post this bug for two reasons. 
1) There are bug reports very similar to this one, but no one has a strong 
link between cs4232 and mouse problem , but often I saw this sound card 
appearing on the cat /proc/interrupts output. So posting this bug could 
help indentifing and debugging the problem.

2) I am ready to reproduce the whole problem, as I have tried many of the 
suggestion for solution of the bugs reports i have found on this site, 
without any improovement on my situation.

Since I'm a newby I need help to know which step to take and what to look 
for. I think I can be of help if guided trhough the process.

I don't know if this bug posting is moderated or not, is so you could 
choose to delete this entry and put it on one of theese, whic are one way 
or another simliar.

List of bug reports which are very similar to my own:

If you keep this as a separate entry would be great if you add those entry 
as dependant to this one or the other way around.

Another hint, if I take control of the linux box with a ssh connection 
everything works fin even with X; but if the system is not responding to 
mouse and keyboard, as stated above, I could not ssh to it, not even ping 

I cry of help and hope:
"Give good hind on how to help myself  for the resolution of this bug. 
It's a pity if such a good OS is left nearly useless by such a problem."

(Please forgive my english as is not my mother language.)
Comment 1 Alan Cox 2003-06-07 14:27:36 EDT
Later RH hands out interrupts to PnP devices to avoid clashes with the PS/2
mouse port. That ought to have fixed this problem but need confirmation

Note You need to log in before you can comment on or make changes to this bug.