Bug 542366 - crash when cancelling to create symlink by ESC
Summary: crash when cancelling to create symlink by ESC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-commander
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a67845ed60b719540abf903716a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-29 13:55 UTC by Alexander Osipenko
Modified: 2009-12-05 00:05 UTC (History)
2 users (show)

Fixed In Version: 1.2.8.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-04 23:37:20 UTC


Attachments (Terms of Use)
File: backtrace (2.89 KB, text/plain)
2009-11-29 13:55 UTC, Alexander Osipenko
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 603301 None None None Never

Description Alexander Osipenko 2009-11-29 13:55:16 UTC
abrt detected a crash.

How to reproduce
-----
1. Open "File/Create Symbolic link" dialog or Ctrl+Shift+F5
2. Press ESC

Comment
-----
Stable reproduced.
Pressing "Cancel" button works fine.

Attached file: backtrace
cmdline: gnome-commander &
component: gnome-commander
executable: /usr/libexec/gnome-commander/gnome-commander
kernel: 2.6.31.5-127.fc12.i686
package: gnome-commander-1:1.2.8.3-1.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 Alexander Osipenko 2009-11-29 13:55:19 UTC
Created attachment 374558 [details]
File: backtrace

Comment 2 Mamoru TASAKA 2009-11-29 14:31:27 UTC
Reproducible

Comment 3 Fedora Update System 2009-12-03 18:53:20 UTC
gnome-commander-1.2.8.3-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-commander-1.2.8.3-2.fc12

Comment 4 Fedora Update System 2009-12-03 18:54:07 UTC
gnome-commander-1.2.8.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-commander-1.2.8.3-2.fc11

Comment 5 Fedora Update System 2009-12-04 06:54:51 UTC
gnome-commander-1.2.8.4-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-commander-1.2.8.4-1.fc10

Comment 6 Vedran Miletić 2009-12-04 18:27:07 UTC
The VERIFIED, FAILS_QA and RELEASE_PENDING bug states are not used by Fedora (they are used in the RHEL process).

I'm closing this bug ahead of time. It is possibly fixed, but Reporter, if you can reproduce it using a current version of Fedora (version 12), please reopen it.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Mamoru TASAKA 2009-12-04 19:04:38 UTC
(In reply to comment #6)
> The VERIFIED, FAILS_QA and RELEASE_PENDING bug states are not used by Fedora
> (they are used in the RHEL process).

Oh, I (the assignee) set the status to RELEASE_PENDING.
I didn't know it, however are there any reason why Fedora assignee
CANNOT use such status?

> I'm closing this bug ahead of time. It is possibly fixed, but Reporter, if you
> can reproduce it using a current version of Fedora (version 12), please reopen
> it.

Please don't close by your decision. This is not happy for both
the reporter and the assignee.

Comment 8 Vedran Miletić 2009-12-04 19:13:36 UTC
Sorry, I see I made a mistake here.

Wiki page[1] doesn't explain why they aren't used, just says they aren't. It's probably because Quality Engineering doesn't work in Fedora the way it does in RHEL.

[1]https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow

Comment 9 Alexander Osipenko 2009-12-04 19:24:38 UTC
Yes, this bug is reproduced in Fedora 12 just as reported, and a have not got
any updates that fixes it, even in Test-Updates repo.

Comment 10 Fedora Update System 2009-12-04 23:37:15 UTC
gnome-commander-1.2.8.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-12-05 00:04:58 UTC
gnome-commander-1.2.8.4-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-12-05 00:05:05 UTC
gnome-commander-1.2.8.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.