Bug 542371 - Notification from Phonon: "Audio Playback Device Does Not Work" if PulseAudio is installed.
Notification from Phonon: "Audio Playback Device Does Not Work" if PulseAudio...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: phonon (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 09:03 EST by Luc Van Rompaey
Modified: 2010-01-08 14:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-08 14:48:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hardware Information (cfr. "https://fedoraproject.org/wiki/How_to_debug_sound_problems") (35.92 KB, text/plain)
2009-11-29 09:06 EST, Luc Van Rompaey
no flags Details
Output from "pulseaudio -vvvvv" (103.50 KB, text/plain)
2009-11-29 09:11 EST, Luc Van Rompaey
no flags Details
Output from "pacmd ls" (64 bytes, text/plain)
2009-11-29 09:13 EST, Luc Van Rompaey
no flags Details

  None (edit)
Description Luc Van Rompaey 2009-11-29 09:03:13 EST
Newly installed Fedora 12 from "Fedora 12 x86_64 Live KDE" CD.

Whenever I log in to the KDE desktop environment, a "Notification from Phonon" appears, stating: "The audio playback device HDA ATI SB (ALC889A Analog) does not work. Falling back to PulseAudio Sound Server." The KDE logon sound is not produced.

According to "https://fedoraproject.org/wiki/How_to_debug_sound_problems," the easiest way to determine if PulseAudio is the culprit, is to remove alsa-plugins-pulseaudio, which I did, but which didn't help. The only difference is, that the notification from Phonon now says: "Falling back to ." (just blank, instead of "PulseAudio Sound Server").

HOWEVER, if I remove pulseaudio ("yum remove pulseaudio"), the problem is gone: No more "Notification from Phonon," and the KDE logon sound gets produced as expected.
Comment 1 Luc Van Rompaey 2009-11-29 09:06:12 EST
Created attachment 374562 [details]
Hardware Information (cfr. "https://fedoraproject.org/wiki/How_to_debug_sound_problems")
Comment 2 Luc Van Rompaey 2009-11-29 09:11:46 EST
Created attachment 374563 [details]
Output from "pulseaudio -vvvvv"

Once the command appeared to produce no more output, I ran "pulseaudio -k" from another command window, and the "pulseaudio -vvvvv" command terminated.
Comment 3 Luc Van Rompaey 2009-11-29 09:13:39 EST
Created attachment 374564 [details]
Output from "pacmd ls"
Comment 4 Adam Williamson 2009-12-01 16:01:15 EST
"According to "https://fedoraproject.org/wiki/How_to_debug_sound_problems," the
easiest way to determine if PulseAudio is the culprit, is to remove
alsa-plugins-pulseaudio, which I did, but which didn't help."

Honestly, that's a bit of shorthand; it only works for things which output natively to ALSA. If whatever's broken outputs natively to Pulse, it doesn't help. I should probably adjust the page to explain that.

I'm adding Kevin Kofler to CC as he may be able to explain what it is KDE's trying to do here and what's failing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kevin Kofler 2009-12-01 16:25:54 EST
This is not a bug in PulseAudio, it's normal that Phonon cannot output to the hardware device directly if PulseAudio is running. The real bug is how Phonon and the F12 KDE Live CD are set up.

Let me explain: due to an oversight, the xine-lib-pulseaudio output plugin is missing from the F12 KDE Live image. This means that phonon-backend-xine cannot output to PulseAudio natively, which it normally gives the highest priority to. So it first tries the hardware device directly, which obviously fails as it's already used by PulseAudio (and this is perfectly normal), then it falls back to the PulseAudio ALSA plugin (that's the "PulseAudio Sound Server" device in Phonon). A complicating issue is that Phonon remembers device priorities, so even if you install xine-lib-pulseaudio afterwards, the priorities are still messed up.

What we are doing to fix this is twofold:
1. We're making sure the xine-lib-pulseaudio output plugin gets pulled in by an update. I pushed an update to the kde-settings-pulseaudio package (which is on the live image) which adds it as a dependency to updates-testing (it was a dependency of kde-settings-pulseaudio until F11, we removed it when we tried out phonon-backend-gstreamer as the default and forgot to put it back when we switched back; and by the way, gstreamer-plugins-good, which provides GStreamer's PulseAudio output plugin, is also missing on the KDE Live image, so even if we hadn't reverted to phonon-backend-xine as the default Phonon backend, we'd still have had a problem), but this solution is going to be superceded by a xine-lib update which will just include the PulseAudio output plugin in the main package (it only requires libpulse, i.e. pulseaudio-libs, which is dragged in by lots of other stuff anyway, and PulseAudio is our default sound solution, so it doesn't make sense to have this in a subpackage).
2. To solve the issue with remembered device priorities, we will be testing a new Phonon snapshot which includes changes by Colin Guthrie from Mandriva which detect whether PulseAudio is running, and when it is, offer only PulseAudio as a device, as it's the only one which is going to work anyway.

In addition, we are trying to get the pulseaudio package to provide the device-manager module which has been contributed to upstream by Colin Guthrie (see bug 541419), which will provide a device selection through PulseAudio in that same Phonon snapshot we'll be testing, i.e. a device selection that will actually work. But without the device-manager, the device selection will simply be limited to "PulseAudio" when PulseAudio is running, which solves the immediate issue here (the messed up priorities).

I hope this clears things up. In any case, the KDE SIG is already aware of this problem, it's a KDE/Phonon issue (and a quite serious one) and we're working on fixing it ASAP.
Comment 6 Kevin Kofler 2010-01-08 14:48:56 EST
The problem as described in comment #5 has been fixed now: #1 in xine-lib-1.1.16.3-5.fc12, #2 by the Phonon 4.3.80 update which was part of the KDE 4.3.4 update set. If you're still seeing similar issues after installing these updates and restarting KDE, please file a separate bug.

Note You need to log in before you can comment on or make changes to this bug.