Bug 542456 - udev and hal rules should not be configurable
udev and hal rules should not be configurable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 15:31 EST by Dan Nicholson
Modified: 2009-12-25 03:23 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.1-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-25 03:23:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't make udev or hal rules configurable (1.26 KB, patch)
2009-11-29 15:31 EST, Dan Nicholson
no flags Details | Diff

  None (edit)
Description Dan Nicholson 2009-11-29 15:31:36 EST
Created attachment 374619 [details]
Don't make udev or hal rules configurable

The libmtp udev and hal rules are not intended to be user configurable, so they should set %config(noreplace). Further, the udev rules should live in /lib/udev/rules.d. Attached is a patch to accomplish this.
Comment 1 Linus Walleij 2009-12-01 12:17:34 EST
OK I applied this patch to -devel, and to F12 as well, do you think
it warrants rolling a new package or should I wait for the next
release instant?
Comment 2 Fedora Update System 2009-12-01 12:33:42 EST
libmtp-1.0.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libmtp-1.0.1-2.fc12
Comment 3 Fedora Update System 2009-12-03 00:06:30 EST
libmtp-1.0.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libmtp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12566
Comment 4 Fedora Update System 2009-12-25 03:23:36 EST
libmtp-1.0.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.