This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 542524 - http://documentation-stage.bne.redhat.com doesn't function as expected under IE7/IE8
http://documentation-stage.bne.redhat.com doesn't function as expected under ...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Joshua Wulf
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 21:29 EST by Darrin Mison
Modified: 2014-10-19 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-28 19:19:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot, IE8 in Windows7 (119.88 KB, image/png)
2009-11-29 21:30 EST, Darrin Mison
no flags Details

  None (edit)
Description Darrin Mison 2009-11-29 21:29:03 EST
Description of problem:
http://documentation-stage.bne.redhat.com doesn't function as expected under IE7/IE8

Steps to Reproduce:
1. go to http://documentation-stage.bne.redhat.com in IE7 or IE8
2. navigate to a book via the menu
3. click on either book title, html or html-single links
  
Actual results:
It seems that every time you click the link it opens another copy of the menu pane nested within the original pane.   The attached screenshot shows it in IE8 mode, it does the same thing in IE7 compatibility mode but it doesn't have the scrollbars.

If you click on the pdf itdownloads as expected.

Expected results:
The book is displayed.

Additional info:
Comment 1 Darrin Mison 2009-11-29 21:30:54 EST
Created attachment 374661 [details]
screenshot, IE8 in Windows7
Comment 2 Darrin Mison 2009-11-29 21:33:00 EST
also, when clicking the book title, html or html-single links, the book doesn't display
Comment 3 Jeff Fearn 2009-11-30 20:45:08 EST
This is due to window.top.location not working as expected in IE7/8 ... haven't been able to track down an alternative yet.
Comment 4 Jeff Fearn 2010-02-25 05:38:33 EST
This is due to IE 7/8 not handling object as expected. Switched from object to iframe.

All books will need to be rebuilt with publican 1.5. Website package also needs to be rebuild and deployed.
Comment 5 Fedora Update System 2010-02-26 00:24:02 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 6 Fedora Update System 2010-02-26 00:27:38 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 7 Fedora Update System 2010-02-26 00:27:51 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 8 Fedora Update System 2010-02-26 00:27:57 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 9 Fedora Update System 2010-02-26 00:30:07 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 10 Fedora Update System 2010-02-26 00:34:14 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 11 Fedora Update System 2010-02-26 22:28:52 EST
publican-1.5-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-02-26 22:44:37 EST
publican-1.5-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.