Bug 54262 - Freeze with multithread app under kernel 2.4.10
Summary: Freeze with multithread app under kernel 2.4.10
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gdb   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-02 16:31 UTC by Miguel Freitas
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 16:31:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miguel Freitas 2001-10-02 16:31:34 UTC
Description of Problem:

I used to debug Xine (a gpl video player, heavly multithreaded)
with gdb-5.0rh-16 without any problems. Upgrading to 2.4.10
makes xine freeze under gdb at a pthread_create function.
Turning back to 2.4.9 fixes the problem (however i like 2.4.10
performance! :)

(I know this issue must be evaluated with care given the
"experimental" VM just integrated into kernel. However i 
think this kind of change must not have influence over
user space apps).

Version-Release number of selected component (if applicable):
gdb-5.0rh-16

How Reproducible:
Always

Steps to Reproduce:
1.install kernel 2.4.10
2.get xine sources (http://xine.sf.net)
3.make debug; sudo make install-debug
4.run xine under gdb
 
Actual Results:
During initialization Xine creates several threads. It seems
to freeze at the very first of them.

Expected Results:
It would just finish initializing and work!

Additional Information:
Program compiled with gcc-2.96rh-97, using glibc-2.2.4-8.

Comment 1 Trond Eivind Glomsrxd 2001-10-04 19:21:40 UTC
Reopen if it happens with a kernel we support. 2.4.10 is known to be broken in
many areas.

Comment 2 Miguel Freitas 2001-10-07 22:13:38 UTC
Just a quick note: the problem is gone with kernel 2.4.11-pre4



Note You need to log in before you can comment on or make changes to this bug.