Bug 54271 - Installer hung to the point that I can't even determine which package it's installing
Installer hung to the point that I can't even determine which package it's in...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-02 15:44 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-11 18:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-02 15:44:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
The machine hung (though the mouse still moves) so I'll have to transcribe this by hand:
--------------
Traceback (inntermost last):
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in run rc = self.todo.doInstall()
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1765, in doInstall self.fstab.turnOnSwap(self.instPath)
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 531, in turnOnSwap searchPath = 1)
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 48, in execWithRedirect raise RuntimeError, command + " can not be run"
RuntimeError: /usr/sbin/mkswap can not be run
-----------------

I couldn't scroll the error window byt CTRL-ALT-Backspace dropped me out of X-windows so I could see the error on the screen. 


 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run the 7.1 installer on a Compaq Presario 7222  (yeah - I know.  I hate compaq too, but it was lying around the office and I want to 
show 
the windoze weenies that it can still be a useable machine)
2.Wait
3.
	

Actual Results:  It hung

Expected Results:  It shouldn't have hung

Additional info:

I tried to reboot and start the install over and it doesn't even get that far. I now get:
--------
...
checking for writeable /tmp... yes
running install...
running /sbin/loader
Running anaconda - please wait...
exec: Input/output error
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
....
-------------------
Comment 1 Brent Fox 2001-10-02 15:52:24 EDT
When the crash occurs, can you press <Ctrl><Alt><F4> and see if there are any
error messages related to the cdrom?

Are these the retail cd's or did you burn them yourself?  The reason I ask is
that there could have been a problem during the download that caused the ISO
images to be corrupted.
Comment 2 Need Real Name 2001-10-11 18:18:00 EDT
I burned the CDs and have used them since without a problem.  There were no CD-ROM related issues.  Also, I figured out what the 
problem was, or at least how to get around it.  I had to download and run a configuration utility from Comquaq to get it to use any OS 
other than win98.  BIOS reconfigured and the box is now RedHatted.

Thanks for the response.
Comment 3 Brent Fox 2001-10-15 14:02:00 EDT
Ok.  Must have been some weird Compaq hardware problem.  Glad to know things are
working now.

Note You need to log in before you can comment on or make changes to this bug.