Bug 54274 - support for Adaptec 5400S raid controller
Summary: support for Adaptec 5400S raid controller
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: roswell
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-02 21:19 UTC by Jonathan Fraser
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-05 16:39:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Fraser 2001-10-02 21:19:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; NTC User)

Description of problem:
The aacraid driver reports its logical drives as removable media.
Anaconda won't install to removable media. 





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do an install of roswell onto an adaptec 5400S raid controller.
2.
3.
	

Actual Results:  Anacoda reports no installable boot device.
Cannot run fdisk or druid from anaconda.  fdisk works fine from
shell.

Expected Results:  Should have listed aacraid devices as installable 
devices.

Additional info:

        A check was put into anaconda in isys/isys.c
in the function doIsScsiRemovable() to work around the fact that
adaptec aac raid controllers report the drives as being removable media.
The check was specific to  DELL and HP branded controllers.     
Now there is  an Adaptec branded controller as well.  The inquiry
string returned is:
 
 Vendor: ADAPTEC   Model: Adaptec  xxxxxx


The code needs to make the same check for the string "ADAPTEC".

Comment 1 Brent Fox 2001-10-05 16:39:36 UTC
katzj, weren't you testing something similar yesterday?

Comment 2 Jeremy Katz 2001-10-05 20:12:00 UTC
Worked around in CVS, work-around is to use expert mode as expert mode lets you
install to removable media.

Comment 3 Jeremy Katz 2001-10-05 20:14:13 UTC
Err... let me make that a little bit more clear since that only makes very murky
 sense to me :)

Workaround committed to CVS so that isys won't think that they're removable. 
You can work around the problem without the changed code by using expert mode.


Note You need to log in before you can comment on or make changes to this bug.