Bug 542804 - [abrt] crash detected in compiz-0.8.2-19.fc12 #3 in cairo_surface_destroy () at cairo-surface.c:429
Summary: [abrt] crash detected in compiz-0.8.2-19.fc12 #3 in cairo_surface_destroy () ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz-fusion
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d8b191b83e8d3bd72cafb76d647...
: 545795 547266 547352 549362 552325 554003 556378 570723 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-30 20:02 UTC by Phil Hale
Modified: 2018-04-11 18:28 UTC (History)
13 users (show)

Fixed In Version: compiz-fusion-0.8.2-7.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-09 01:25:12 UTC


Attachments (Terms of Use)
File: backtrace (16.79 KB, text/plain)
2009-11-30 20:02 UTC, Phil Hale
no flags Details

Description Phil Hale 2009-11-30 20:02:40 UTC
abrt detected a crash.

Comment: Using Compiz-Fusion and window manager crashed.
Attached file: backtrace
cmdline: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding --indirect-rendering
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.5-127.fc12.x86_64
package: compiz-0.8.2-19.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 Phil Hale 2009-11-30 20:02:43 UTC
Created attachment 374871 [details]
File: backtrace

Comment 2 Matěj Cepl 2009-12-10 14:39:04 UTC
#2  0x0000003e2002b7a5 in __assert_fail (assertion=
    0x3e27c5fe18 "((*&(&surface->ref_count)->ref_count) > 0)", 
    file=<value optimized out>, line=429, function=<value optimized out>)
    at assert.c:81
        buf = 
    0x2f79c10 "compiz: cairo-surface.c:429: cairo_surface_destroy: Assertion `((*&(&surface->ref_count)->ref_count) > 0)' failed.\n"
#3  0x0000003e27c2ca66 in cairo_surface_destroy (surface=0x2ef80c0)
    at cairo-surface.c:429
        __PRETTY_FUNCTION__ = "cairo_surface_destroy"
#4  0x00007faf88547a7e in textCleanupSurface (data=<value optimized out>)
    at text.c:380
No locals.
#5  textRenderText (data=<value optimized out>) at text.c:439
        surface = {width = 0, height = 15, cr = 0x2f30d40, surface = 
    0x2ef80c0, layout = 0x2f34ba0, pixmap = 0, format = 0x200b130, font = 
    0x2f9e640, screen = 0x1d7afa0}
        retval = 0x0

Comment 3 Matěj Cepl 2009-12-10 14:45:54 UTC
*** Bug 545795 has been marked as a duplicate of this bug. ***

Comment 4 Hamidou Dia 2009-12-12 05:55:01 UTC
Changing title: So that we can triage easily.

@Adel, it looks like it has been fixed upstream with:

http://git.compiz.org/compiz/plugins/text/commit/?h=compiz-0.8&id=f101e9ed8771a3aa32de641b1a3bb43f208812c9

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Adel Gadllah 2009-12-12 23:39:30 UTC
(In reply to comment #4)
> Changing title: So that we can triage easily.
> 
> @Adel, it looks like it has been fixed upstream with:
> 
> http://git.compiz.org/compiz/plugins/text/commit/?h=compiz-0.8&id=f101e9ed8771a3aa32de641b1a3bb43f208812c9
> 
> Regards.


Thanks, will add it to the next update (which should be in testing in ~ one week).

Comment 6 Hamidou Dia 2009-12-18 16:39:26 UTC
*** Bug 547352 has been marked as a duplicate of this bug. ***

Comment 7 Hamidou Dia 2009-12-18 16:40:53 UTC
Hi Adel,

Thanks for the feedback.

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Hamidou Dia 2009-12-18 16:49:55 UTC
*** Bug 547266 has been marked as a duplicate of this bug. ***

Comment 9 Hamidou Dia 2009-12-24 13:23:24 UTC
*** Bug 549362 has been marked as a duplicate of this bug. ***

Comment 10 Chris Campbell 2010-01-04 18:20:34 UTC
*** Bug 552325 has been marked as a duplicate of this bug. ***

Comment 11 Hamidou Dia 2010-01-10 18:32:23 UTC
*** Bug 554003 has been marked as a duplicate of this bug. ***

Comment 12 Jason A. Smith 2010-01-16 02:33:51 UTC
(In reply to comment #5)
> 
> Thanks, will add it to the next update (which should be in testing in ~ one
> week).    

I have not seen any updates yet, and still nothing in the testing repo.  Will we get this anytime soon?

Comment 13 Hamidou Dia 2010-01-21 02:05:16 UTC
*** Bug 556378 has been marked as a duplicate of this bug. ***

Comment 14 jIoSEA3lWwiEaAVy3 2010-03-28 03:30:38 UTC

How to reproduce
-----

Comment 15 Fedora Update System 2010-03-28 12:29:48 UTC
compiz-fusion-0.8.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/compiz-fusion-0.8.2-7.fc12

Comment 16 Adel Gadllah 2010-03-28 15:52:11 UTC
*** Bug 570723 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-03-30 02:23:22 UTC
compiz-fusion-0.8.2-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compiz-fusion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/compiz-fusion-0.8.2-7.fc12

Comment 18 jIoSEA3lWwiEaAVy3 2010-03-30 23:35:13 UTC

Comment
-----
There is a "window" in a taskbar (gnome panel), when I "hover" it or click on it, compiz crashes...
It has an icon of PackageKit-gnome.

Comment 19 jIoSEA3lWwiEaAVy3 2010-03-30 23:38:37 UTC

Comment
-----
It's a window that prevent of an authorisation timeout when updating (when you ignore the polkit message asking you to enter your root password).

Comment 20 Fedora Update System 2010-04-09 01:25:07 UTC
compiz-fusion-0.8.2-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Phil Hale 2010-04-09 15:35:56 UTC
My issues seem to be resolved with the latest package.


Note You need to log in before you can comment on or make changes to this bug.