Bug 542822 - Upgrade data format requested on non-major release update
Upgrade data format requested on non-major release update
Status: CLOSED DUPLICATE of bug 398221
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-30 16:06 EST by Bruno Medeiros
Modified: 2013-07-02 23:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 19:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Medeiros 2009-11-30 16:06:42 EST
Description of problem:

Some days ago I updated my Fedora 11 to Fedora 12. After this update, when I try to start the postresql service, I got an error:

--------------------------------------------------------------
[root@brunojcm-laptop ~]# rpm -q postgresql
postgresql-8.4.1-3.fc12.x86_64
[root@brunojcm-laptop ~]# cat /var/lib/pgsql/data/base/1/PG_VERSION 
8.3
[root@brunojcm-laptop ~]# service postgresql start

An old version of the database format was found.
You need to upgrade the data format before using PostgreSQL.
See /usr/share/doc/postgresql-8.4.1/README.rpm-dist for more information.
--------------------------------------------------------------

Version-Release number of selected component (if applicable):
postgresql-8.4.1-3.fc12.x86_64

How reproducible:
Always, i guess.

Steps to Reproduce:
1. Install some Fedora with PostgreSQL 8.3
2. Create some database
3. Update to PostgreSQL 8.4
4. Start postgresql service
  
Actual results:
PostgreSQL tells me to upgrade the database.

Expected results:
PostgreSQL starts.

Additional info:
The docs mentioned in the message don't have any instructions on how to upgrade de database format.
Comment 1 Tom Lane 2009-11-30 19:21:29 EST
This is the expected behavior.  8.3 to 8.4 *is* a major release upgrade for postgresql --- that's just how that project numbers their releases.  What you need to do to update your data is pg_dumpall in the old installation and load the data into the new one.  It's not something that's easily solved at the packaging level, unfortunately.

*** This bug has been marked as a duplicate of bug 398221 ***

Note You need to log in before you can comment on or make changes to this bug.