Bug 542828 - Underscore in 'Details Filter' breaks filtering - no messages are displayed
Underscore in 'Details Filter' breaks filtering - no messages are displayed
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Events (Show other bugs)
unspecified
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
Jeff Weiss
: SubBug
Depends On:
Blocks: RHQ-2284 JON231
  Show dependency treegraph
 
Reported: 2009-11-30 16:40 EST by Jaroslaw Kijanowski
Modified: 2014-11-09 17:50 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 12:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Kijanowski 2009-11-30 16:40:25 EST
Description of problem:
I have enabled event loggin. Now when I filter events I use 'Details Filter'.
When I try to filter strings that contains the "_" character nothing is displayed although there are events which should match.

Version-Release number of selected component (if applicable):
JON-2.3.0.GA

How reproducible:
Every time

Steps to Reproduce:
1. enable event logging
2. force the server to display some log message with the "_" character
3. search for this message using the 'Details Filter' text box
  
Actual results:
No messages show up

Expected results:
Messages with the "_" character should be displayed

Additional info:
-
Comment 1 Charles Crouch 2010-01-22 10:19:38 EST
This was found using JON against Oracle 10g
Comment 2 Charles Crouch 2010-01-22 11:27:41 EST
I just tried this on PG and it worked fine. Using _ in the Details filter found...

[org.rhq.enterprise.server.measurement.MeasurementCompressionManagerBean] Begin purging data from table [RHQ_MEASUREMENT_DATA_NUM_1D] before [Thu Jan 22 11:00:…
Comment 3 Simeon Pinder 2010-02-01 09:49:33 EST
Fixed: 

svn rev 5278

git hash 41074662511d03f3cbced4c631a2433b2583d6e1

Added new utility, better backslash processing and post pending ESCAPE clause.  For master _ and % processing should be working more correctly than it has been in a long time. 


Reproduce instructions for both Postgres and Oracle:

i) install release on [Postgres || Oracle]
ii) import resources into JON and enable Event logging for RHQ JBossAS (remember double edit and double save on Inventory subtab properties )
iii) restart the Jon server
iv) navigate to RHQ JBossAS resource -> Events and search in the 'Details' field for: CLUSTERED  and a few events featuring $_NON_CLUSTERED should be returned
v) search in same field with NON_CLUSTERED and confirm the same number of results as previous search are returned with an "_" in the search string.  
vi) Rinse and repeat with the other database.
Comment 4 Simeon Pinder 2010-02-02 14:24:08 EST
Charles wants this to be tested with the following database versions to guard against regression:
i) Oracle 10G 
i) Postgres 8.2.* and 8.4.*
Comment 5 Simeon Pinder 2010-02-03 11:57:58 EST
svn 5280 includes changes for escaping % and \ as well in the Resource and Event search queries.


Additional Reproduce instructions for Resource Search:
i) install release on [Postgres || Oracle]
ii) import resources into JON
iii) rename one of the resources to include _, then search for the string without and with underscore. _ search should isolate resource names correctly now.
Comment 6 Corey Welton 2010-02-11 12:06:50 EST
Postgresql 8.4 regression was clean.
Comment 7 Jeff Weiss 2010-02-11 15:27:21 EST
Oracle 10G works too.  Just need Postgres 8.2 now
Comment 8 Corey Welton 2010-02-12 10:17:02 EST
Postgres 8.2 regression was clean.

QA Verified.
Comment 9 wes hayutin 2010-02-16 11:51:26 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 10 wes hayutin 2010-02-16 11:57:46 EST
making sure we're not missing any bugs in rhq_triage
Comment 12 Corey Welton 2010-08-12 12:50:46 EDT
Mass-closure of verified bugs against JON.

Note You need to log in before you can comment on or make changes to this bug.