Bug 54284 - checktime reached for e2fsck message just after e2fsck run
checktime reached for e2fsck message just after e2fsck run
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
6.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-03 03:23 EDT by Linda Riewe
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-03 15:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab, output of "tune2fs -l /dev/hdaX", dmesg (8.00 KB, text/plain)
2001-10-03 03:30 EDT, Linda Riewe
no flags Details

  None (edit)
Description Linda Riewe 2001-10-03 03:23:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
EXT2-fs warning: checktime reached, running e2fsck is recommended

This message displays during boot and is in "dmesg" file.  But the 
tune2fs -l (ell) option that shows the superblock info of my 3 ext2 
partitions (root "/", /home and /boot) all have approximately this info:

Mount count:              2
Maximum mount count:      20
Last checked:             Tue Oct  2 21:16:32 2001
Check interval:           15552000 (6 months)
Next check after:         Sun Mar 31 20:16:32 2002

so you can see that I just ran fsck which I guess would have been e2fsck 
on ext2 partitions.  I ran it by "shutdown -F" which forced the fsck on 
the next boot.

But it keeps giving this message to run e2fsck even though I think I just 
did.

The boot messages say these partitions are all clean.  But the tune2fs -l 
(ell) option says "not clean" - I don't know what that means - maybe just 
that they are in use at the moment?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. shutdown -F -r now
2. (watch the boot messages as fsck runs on ext2 partitions)
3. reboot
4. see the message again:
   EXT2-fs warning: checktime reached, running e2fsck is recommended
	

Actual Results:  This same thing, repeatedly.

Expected Results:  After rebooting by shutdown -F which I think runs 
e2fsck, and then booting again, on the second boot, I don't think I should 
see the message to rerun e2fsck again.

Additional info:

My system is dual-boot RedHat 5.1 with Windows 98.  The Windows partition 
(file type vfat) is visible from the Linux side and I've been using it a 
bit lately.

I don't know if this is an unnecessary message that's not reading the 
count correctly, or if it is confused by daylight savings time, or if 
something bad is about to happen to my file system, possibly bringing down 
the Windows side, too, which would be very bad for me, because I use this 
computer to work.

I have the "dmesg", output of each ext2's "tune2fs -l" (except the swap 
partition's), and the "fstab" file if you would like to look at those.  
Please write me if you know what this is, but I spent a few hours 
searching through groups.google.com and your search engine, too, and 
didn't find something exactly applicable to this.
Comment 1 Linda Riewe 2001-10-03 03:30:19 EDT
Created attachment 33298 [details]
fstab, output of "tune2fs -l /dev/hdaX", dmesg
Comment 2 Linda Riewe 2001-10-03 03:38:40 EDT
Sorry!  That's RedHat 6.1, not 5.1.
Comment 3 Florian La Roche 2001-10-03 15:51:35 EDT
Is this fixed by recompiling e.g. the e2fsprogs version from
RHL 6.2 with "rpm --rebuild <6.2-version>" and installing that
on your machine?

Thanks,

Florian La Roche
Comment 4 Florian La Roche 2002-12-02 09:15:02 EST
Should be working fine for current versions, otherwise please re-open or
open a new one.

Thanks for your feedback,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.