Bug 54285 - Store is not using appropriate web_user_site_info records
Summary: Store is not using appropriate web_user_site_info records
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Store
Version: current
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Web Development
QA Contact: Web Development
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-03 13:01 UTC by Jay Turner
Modified: 2015-01-07 23:51 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2003-06-25 15:17:41 UTC


Attachments (Terms of Use)

Description Jay Turner 2001-10-03 13:01:14 UTC
Description of Problem:
When placing an order through www.webdevel.redhat.com, the incorrect site
records are getting pulled into the order.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Log into www.webdevel.redhat.com and then edit the billing address for
the user, thus creating a new 'B' site record
2. Now place an order and notice that in the address verification section,
you are presented with the original billing site info (not the new edits)
3. Finish placing the order and notice that yet another site record is
created with the original site information, and then attached to the order

Actual Results:
The order should always pull the latest site_info records for billing and 
shipping, then use those on the order is the customers doesn't edit them,
thus creating the need for new records.

Expected Results:


Additional Information:

Comment 1 Tom Lancaster 2001-10-23 22:02:33 UTC
This should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.