Bug 542869 - Xastir mouse-button-3 popups stopped working in FC12 (maybe FC11)
Xastir mouse-button-3 popups stopped working in FC12 (maybe FC11)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xastir (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-30 20:46 EST by Alan Crosswell
Modified: 2010-02-04 14:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 14:36:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Crosswell 2009-11-30 20:46:10 EST
Description of problem:

Can't get a right-click popup to work.  Instead the cursor pointer switches from leaning left to leaning right and hangs the window (can't move pointer focus away from Xastir main window).

Version-Release number of selected component (if applicable):

xastir-1.9.6-3.fc12.i686

How reproducible:

always

Steps to Reproduce:
1. launch xastir
2. deal with the new user one time configuration (says NOCALL)
3. right click anywhere in the map display
  
Actual results:
pointer leans right but no popup menu

Expected results:
a popup menu

Additional info:
Seems to have changed with some recent Xorg change.  Have tested with multiple window managers as well as building from source using both lesstif (default) and openmotif, all with the identical results.   Has worked previously on earlier FC releases and works on a ubuntu 9.04 live release.  Not sure if this broken in FC11 or 12.  But I'm pretty sure it was FC12 (and rawhide leading up to it).
Comment 1 Tate 2009-12-01 10:17:19 EST
I can offer that this did not occur for me in F11. I've 4 different (updated from F10 and new installs) PCs that were running F11 and never encountered this problem. I am now seeing this problem - as described -  on these same machines after upgrades (3) and a clean install of F12.
Comment 2 Kevin Paetzold 2009-12-04 14:32:42 EST
I can also confirm that this did not happen with Fedora 11 (or previous).  I did complete install of fedora 12 (ie. not an update).  I can also confirm that this problem occurs on 4 fedora 12 machines i now have and seems 100% reproducable (easily).  Initially I was using my own build of xastir but I have now tested with the fedora supplied RPM package and confirmed that also has the same problem.

If, I run xastir on my fedora 12 machine over an "ssh -X" connection from a non fedora 12 machine (ie. my display and X server not on fedora 12) everything works OK.  

Problem only occurs when the display is on a fedora 12 machine (ie. if I use ssh from one fedora machine to another the problem still occurs).
Comment 3 eric@christensenplace.us 2009-12-07 09:29:47 EST
Hmmm... I'm not seeing this problem with my install.  I wonder if it is reproducible using the previous version of Xastir.
Comment 4 Lucian Langa 2009-12-07 09:57:25 EST
It appears to be a problem with lesstif and xorg.
See: https://bugzilla.redhat.com/show_bug.cgi?id=543647 for a similar report.
Comment 5 Tate 2009-12-16 11:19:59 EST
I just upgraded one older PC from Fedora 9 to 10, then to 11 and finally to 12.

Then performed a clean CVS install of Xastir - the problem did NOT appear. I haven't noticed if there've been updates on pertinent components or not - but could this have been fixed?

I need to do full updates and re-build xastir on a machine that does have this problem.
Comment 6 Lucian Langa 2009-12-16 14:58:27 EST
Well, I tried latest cvs but the problem is still there. I couldn't see any difference.

Anyway I just posted this upstream (as a temporary/dirty fix):

"I managed to get a working popup menu by accident.
I had NumLock turned on and pressed right click. Instantly I got
'Modifiers Found' popup and the actual popup that wasn't display before.
Turning off numlock and closing the Modifiers popup, the actual popup
works correctly now.
Unfortunately closing xastir and starting it again (without numlock on)
won't work the old issue remains."
Comment 7 Kevin Paetzold 2009-12-16 16:47:38 EST
I can confirm the workaround using numlock as described above (comment #6).  That avoidance also seems to work for me just as described.

Seems like it would be good to see the differences between a package list on a fedora 12 system that works vs. one that does not work.
Comment 8 Kevin Paetzold 2010-01-28 15:35:30 EST
Another avoidance for this issue (in another app) is reported in 
https://bugzilla.redhat.com/show_bug.cgi?id=532621

That avoidance is to use shift with the first rightclick
instead of using numlock during the first rightclick
Comment 9 Lucian Langa 2010-02-04 14:36:39 EST
latest xorg build fixes this issue:

https://admin.fedoraproject.org/updates/F12/FEDORA-2010-1365

Note You need to log in before you can comment on or make changes to this bug.