Bug 54295 - Sawfish Bindings modifier of -control- breaks xterm menus
Sawfish Bindings modifier of -control- breaks xterm menus
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: sawfish (Show other bugs)
roswell
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 50259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-03 14:52 EDT by jrjohns
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 16:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jrjohns 2001-10-03 14:52:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2 i686)

Description of problem:
After installing Red Hat 7.2 Beta (Roswell) and logging in under GNOME, I
could not hold down the Left Ctrl key and use the mouse buttons over an
Xterm to access the menus.

The key binding for sawfish, accessable in
GNOME->Programs->Settings->Desktop->"Window Manager"->"Run Configuration
Tool for Sawfish"->Bindings (say that three times fast!), were initially
set to use "control" as the modifier key.  This default interrupts normal
use of control in other applications such as Xterm.

I tried changing the modifier to "alt", and this brought back my Xterm
windows, but I could no longer access the Sawfish controls with
LeftAlt-MiddleMouseButton.  I settled on "shift" because I do not use any
applications that require LeftShift-MouseButton actions, and this seemed to
give me access to both the Xterm menus and the Sawfish menus.

I was also confused by the existance of both the path above (to bindings)
and a separate path of GNOME->Programs->Settings->"Sawfish window manager",
which does not have a Bindings entry.  It took me a while to determine that
there was another place I could configure Sawfish and locate the Bindings
controls.  "Bindings" is also missing if I use the Nautilus "Start Here"
program and access Preferences:///Sawfish.  

I would prefer a single interface to configuring the window manager rather
than several, or at very least, to see all of the configuration options
consistently available through all interfaces.  The Bindings controls are
too deeply buried in menus.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install RedHat 7.2 beta
2. Launch Gnome
3. Hold Ctrl and Right Mouse Button
	

Actual Results:  No menu	

Expected Results:  VT Fonts menu should appear.

Additional info:
Comment 1 Havoc Pennington 2001-10-03 15:29:20 EDT
I would agree on the complexity of the config interface. Working on that.

The control key is not actually our default; instead, for some users who
upgrade, Sawfish decides to switch to control (we ship with alt). The problem
hasn't been tracked down yet. For fresh user accounts it should be alt.
Comment 2 jrjohns 2001-10-03 15:33:42 EDT
Hate to break this news:  This was on a new install, not an upgrade.  It was a
"Custom" install though; perhaps the bug is something common to Custom/Upgrade
installs but different from Server/Workstation installs?
Comment 3 jrjohns 2001-10-03 15:35:12 EDT
Wait, I take that back.  It was a new install, BUT my account is NFS mounted
from another box.  It probably picked up and upgraded that when I started GNOME
and changed it to control.  Sorry for the confusion.
OK... so it's a strange upgrade issue.
Comment 4 Havoc Pennington 2001-10-03 15:58:02 EDT
Right, the issue is that some old version of Sawfish wrote something weird in 
a config file in your home directory, that somehow causes the new version of
Sawfish to switch to alt. Twilight zone. ;-)
Comment 5 Havoc Pennington 2001-10-03 15:58:26 EDT
I meant "switch to control" obviously, sorry.
Comment 6 Havoc Pennington 2002-02-25 21:17:27 EST
*** Bug 50259 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2002-07-02 18:26:21 EDT
Sawfish is no longer the default WM, and I believe now defaults to almost no
keybindings.

Note You need to log in before you can comment on or make changes to this bug.