Bug 54306 - dec21554 (drawbridge) causes hang as cqparray is erroneously accessed
Summary: dec21554 (drawbridge) causes hang as cqparray is erroneously accessed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.1
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-04 04:59 UTC by Dick
Modified: 2014-03-17 02:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-05 16:31:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dick 2001-10-04 04:59:19 UTC
Description of Problem:

The system has a blade in it with a dec21554 non-transparent bridge but it 
is NOT a cpparray SCSI RAID controller.  During installation (at the very 
first) the installation detects the 21554 as a cpqarray controller and 
hangs trying to access a cpqarray (which is not in the system or even the 
building)

Version-Release number of selected component (if applicable):


How Reproducible:



Steps to Reproduce:

1. Use a system with a master and non-system master cpu blade which uses a 
dec 21554 (yes this is Compact PCI, but it should work the same on regular 
pci with a card that has a 21554 which is NOT a cpqarray card).

2.  Put the 7.1 CD in the drive and boot.  Before the initial blue install 
screen prints the installing Anaconda message at the bottom (that never 
appears) a box about the cpqarray appears on the screen and it hangs there 
until rebooted.  If you can put a cdrom on the Non-System cpu blade, the 
problem will happen from that side of the 21554 bridge also.

3. To work around the problem on the master CPU blade, remove the non-
master cpu (with the 21554) before installing.  This is harder to do on 
the non-master cpu since the 21554 is soldered to the board.


Actual Results:

It hangs

Expected Results:


Additional Information:

Comment 1 Dick 2001-10-05 16:17:29 UTC
Why does this bug report not show up when I seasrch for it on :

http://interchange.redhat.com/bugs/



Comment 2 Brent Fox 2001-10-05 16:24:32 UTC
Because Interchange is a separate product from Red Hat Linux.  Interchange is an
E-commerce platform, so you were searching the bug reports for that product, not
Red Hat Linux.

Comment 3 Brent Fox 2001-10-05 16:30:46 UTC
I'm not familiar with the DEC 21554, but I can see that the entry in kudzu's
pcitable has the cpqarray driver associated with this card:

0x1011  0x0046  "cpqarray"      "DEC|DECchip 21554"

I'm changing the component for this bug report to kudzu.

Comment 4 Bill Nottingham 2001-10-09 19:13:20 UTC
Will be fixed in kudzu-0.99.26-1; thanks!


Note You need to log in before you can comment on or make changes to this bug.