Bug 543081 - Please add Maven depmap fragments
Please add Maven depmap fragments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jetty (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 540986
  Show dependency treegraph
 
Reported: 2009-12-01 11:58 EST by Mary Ellen Foster
Modified: 2010-01-05 17:45 EST (History)
2 users (show)

See Also:
Fixed In Version: 6.1.20-7.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 17:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2009-12-01 11:58:21 EST
Description of problem:

Please add Maven depmap fragments to the spec file as specified here:
  https://fedoraproject.org/wiki/Packaging/Java#maven
This makes it possible for other packages that use Maven to build against the
jetty library.

The appropriate calls to %add_to_maven_depmap are probably:
%add_to_maven_depmap org.mortbay.jetty jetty 6.1.20 JPP/jetty jetty
%add_to_maven_depmap org.mortbay.jetty jetty-util 6.1.20 JPP/jetty jetty-util


Version-Release number of selected component (if applicable):
jetty-6.1.20-6.fc12.noarch
Comment 1 Mary Ellen Foster 2009-12-03 06:05:19 EST
I'd like to add the necessary Maven metadata myself, using provenpackager access. If you don't want me to do this, please let me know before Saturday 5 December.
Comment 2 Mary Ellen Foster 2009-12-03 06:44:47 EST
Sorry, never mind -- looks like the change is pending in CVS already. (Thanks! :) )
Comment 3 Mary Ellen Foster 2009-12-11 11:14:07 EST
Hi! Is there any chance you could push the update that seems to be pending in the CVS for jetty? For what it's worth, it seems to work fine for me ...
Comment 4 Fedora Update System 2009-12-11 13:36:38 EST
jetty-6.1.20-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/jetty-6.1.20-7.fc12
Comment 5 Fedora Update System 2009-12-15 20:20:38 EST
jetty-6.1.20-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jetty'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13230
Comment 6 Fedora Update System 2010-01-05 17:45:34 EST
jetty-6.1.20-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.