Bug 543105 - SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.
SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.
Status: CLOSED DUPLICATE of bug 537163
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-12-01 12:38 EST by Dave
Modified: 2009-12-03 11:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-01 15:26:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave 2009-12-01 12:38:24 EST

SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.

Detailed Description:

SELinux denied access requested by qemu-kvm. It is not expected that this access
is required by qemu-kvm and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug

Additional Information:

Source Context                system_u:system_r:svirt_t:s0:c576,c766
Target Context                system_u:object_r:virt_content_t:s0
Target Objects                sr0 [ blk_file ]
Source                        qemu-kvm
Source Path                   /usr/bin/qemu-kvm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-0.11.0-11.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-49.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              #1 SMP Sat Nov 21 16:12:37 EST 2009 i686 i686
Alert Count                   1
First Seen                    Tue 01 Dec 2009 08:46:22 AM MST
Last Seen                     Tue 01 Dec 2009 08:46:22 AM MST
Local ID                      163f8aa4-df1a-432d-8f64-07d4680989d4
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1259682382.580:31409): avc:  denied  { write } for  pid=2705 comm="qemu-kvm" name="sr0" dev=tmpfs ino=3519 scontext=system_u:system_r:svirt_t:s0:c576,c766 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_file

node=(removed) type=SYSCALL msg=audit(1259682382.580:31409): arch=40000003 syscall=5 success=no exit=-13 a0=bfae7c47 a1=9002 a2=0 a3=bfae7c47 items=0 ppid=1 pid=2705 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-kvm" exe="/usr/bin/qemu-kvm" subj=system_u:system_r:svirt_t:s0:c576,c766 key=(null)

Hash String generated from  selinux-policy-3.6.32-49.fc12,catchall,qemu-kvm,svirt_t,virt_content_t,blk_file,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t virt_content_t:blk_file write;
Comment 1 Daniel Walsh 2009-12-01 15:26:15 EST

*** This bug has been marked as a duplicate of bug 537163 ***

Note You need to log in before you can comment on or make changes to this bug.