This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 543117 - SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.
SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.
Status: CLOSED DUPLICATE of bug 537163
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:450018ba66d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-01 13:05 EST by Jerry James
Modified: 2009-12-01 15:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 15:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2009-12-01 13:05:39 EST
Summary:

SELinux is preventing /usr/bin/qemu-kvm "write" access on sr0.

Detailed Description:

SELinux denied access requested by qemu-kvm. It is not expected that this access
is required by qemu-kvm and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:svirt_t:s0:c98,c596
Target Context                system_u:object_r:virt_content_t:s0
Target Objects                sr0 [ blk_file ]
Source                        qemu-kvm
Source Path                   /usr/bin/qemu-kvm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-0.11.0-11.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-46.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.6-145.fc12.x86_64 #1 SMP Sat Nov 21
                              15:57:45 EST 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 01 Dec 2009 11:03:13 AM MST
Last Seen                     Tue 01 Dec 2009 11:03:13 AM MST
Local ID                      f5e9c9ee-58c7-4b3a-aa6b-33b88c6a09b0
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1259690593.720:31062): avc:  denied  { write } for  pid=9080 comm="qemu-kvm" name="sr0" dev=tmpfs ino=3850 scontext=system_u:system_r:svirt_t:s0:c98,c596 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_file

node=(removed) type=SYSCALL msg=audit(1259690593.720:31062): arch=c000003e syscall=2 success=no exit=-13 a0=7fff51289660 a1=1002 a2=1a4 a3=30 items=0 ppid=1 pid=9080 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-kvm" exe="/usr/bin/qemu-kvm" subj=system_u:system_r:svirt_t:s0:c98,c596 key=(null)



Hash String generated from  selinux-policy-3.6.32-46.fc12,catchall,qemu-kvm,svirt_t,virt_content_t,blk_file,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t virt_content_t:blk_file write;
Comment 1 Jerry James 2009-12-01 13:08:01 EST
I inserted the Fedora 12 Live CD in my drive, fired up virt-manager, and told it to make a new virtual machine using the CD to boot.  I then got this AVC denial.  Note that /dev/sr0 is my CD/DVD drive, so writing to it is impossible anyway.
Comment 2 Daniel Walsh 2009-12-01 15:26:55 EST

*** This bug has been marked as a duplicate of bug 537163 ***

Note You need to log in before you can comment on or make changes to this bug.