Bug 54313 - ntpd runs with a bad user id
ntpd runs with a bad user id
Status: CLOSED DUPLICATE of bug 50698
Product: Red Hat Public Beta
Classification: Retired
Component: ntp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2001-10-04 03:56 EDT by Alain RICHARD
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-04 03:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alain RICHARD 2001-10-04 03:56:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0b1; Mac_PowerPC)

Description of problem:
The ntpd daemon is running with a bad user id :
1075388500 11308  0.0  1.6 2040 2032 ?       SL   Oct03   0:00 ntpd 
-U ntp

it is then unable to access/update some of its files and output the 
following error in /var/log/message at regular times :

Oct  4 04:23:38 pbing ntpd[978]: can't open /etc/ntp/drift.TEMP: 
Permission denied

There is user/group id for ntp  to run in the /etc/passwd file :


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
I have seen this on two differents installations of roswell. On each 
one, this is 100% reproductible just by running the ntpd daemon 
(service ntpd start).

Actual Results:  the ntpd daemon runs with a random big user id 
(example : 1075392596).

Expected Results:  the ntpd should be run as user id ntp (38).

Additional info:
Comment 1 Harald Hoyer 2001-10-04 04:46:04 EDT

*** This bug has been marked as a duplicate of 50698 ***

Note You need to log in before you can comment on or make changes to this bug.