Bug 54316 - Cannot rebuild Guppi from the .src.rpm on RH71
Cannot rebuild Guppi from the .src.rpm on RH71
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: Guppi (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 05:23 EDT by Need Real Name
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 22:22:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-04 05:23:21 EDT
Hi!

When I try:
rpm --rebuild Guppi-0.35.5-7.src.rpm

I obtain:
....
/bin/sh ../../libtool --mode=link gcc  -O2 -march=i386 -mcpu=i686 -Wall
-Wunused   -o libguppispecfns.la -rpath /usr/lib -version-info 11:0:0  -lm
-lglib bdtr.lo btdtr.lo chdtr.lo choose.lo const.lo fdtr.lo gamma.lo
gdtr.lo hypergeom.lo igam.lo igami.lo incbet.lo incbi.lo mtherr.lo nbdtr.lo
ndtr.lo ndtri.lo pdtr.lo polyeval.lo stdtr.lo unity.lo
../libguppiuseful/libguppiuseful.la 
libtool: link: error: cannot link shared libraries into libtool libraries
make[3]: *** [libguppispecfns.la] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/Guppi-0.35.5/src/libguppispecfns'make[2]: ***
[all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/Guppi-0.35.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/Guppi-0.35.5'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.95489 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.95489 (%build)
Comment 1 Bill Nottingham 2001-10-04 15:36:39 EDT
It probably needs to buildprereq the current (rawhide) libtool.
Comment 2 Bill Nottingham 2002-02-05 22:22:28 EST
What release are you trying to build on?
Comment 3 Bill Nottingham 2002-02-05 22:24:24 EST
Nevermind, the buildprereq will be added in Guppi-0.40.3-3.

Note You need to log in before you can comment on or make changes to this bug.