Bug 543177 - devhelp-devel should properly depend on webkitgtk-devel
Summary: devhelp-devel should properly depend on webkitgtk-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: devhelp
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-01 20:33 UTC by Sven Herzberg
Modified: 2010-01-04 21:20 UTC (History)
1 user (show)

Fixed In Version: 2.28.1-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-04 21:20:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 603623 None None None Never

Description Sven Herzberg 2009-12-01 20:33:03 UTC
Description of problem:
devhelp-devel's pkg-config file should expose the webkit dependency (and the rpm should reflect this).

Version-Release number of selected component (if applicable):
$ yum info devhelp-devel
Loaded plugins: presto, refresh-packagekit
Installed Packages
Name       : devhelp-devel
Arch       : i686
Version    : 2.28.1
Release    : 1.fc12
[...]

How reproducible:
Process include file with cpp

Steps to Reproduce:
1. echo "#include <devhelp/dh-assistant-view.h>" | cpp - `pkg-config --cflags libdevhelp-1.0` > /dev/null
  
Actual results:
In file included from <stdin>:1:
/usr/include/devhelp-1.0/devhelp/dh-assistant-view.h:24:27: error: webkit/webkit.h: No such file or directory

Expected results:
no errors

Additional info:

Comment 1 Matthew Barnes 2009-12-02 14:57:27 UTC
The devhelp-devel package was the WebKit-gtk-devel requirement.   Looks like it's just missing from libdevhelp-1.0.pc.  I'll patch it for Fedora and notify upstream.

Comment 2 Matthew Barnes 2009-12-02 17:09:14 UTC
Fixed in devhelp-2.28.1-2.fc12 and devhelp-2.29.3-2.fc13.

See also: https://bugzilla.gnome.org/show_bug.cgi?id=603623

Comment 3 Fedora Update System 2009-12-02 17:27:32 UTC
devhelp-2.28.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/devhelp-2.28.1-2.fc12

Comment 4 Fedora Update System 2009-12-04 23:51:50 UTC
devhelp-2.28.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update devhelp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12669

Comment 5 Fedora Update System 2010-01-04 21:19:57 UTC
devhelp-2.28.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.