Bug 5432 - Linuconf doesn't set route through aliases
Linuconf doesn't set route through aliases
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: linuxconf (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-29 06:09 EDT by Milan Kerslager
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 11:21:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 1999-09-29 06:09:15 EDT
If I set static route to some network that go through alias
this route will not be set because there is line in
/etc/sysconfig/static-routes:
any net 194.108.45.16 netmask 255.255.255.240 gw
194.108.45.131

so /etc/sysconfig/network-scripts/ifup-routes can't set up
this route (this script depend on eth1:1 instead of word
'any' at the beginnig of the line above - linuxconf gives
parameter eth1:1).

The solution is to set this route with proper interface (ie.
alias - eth1:1) to the begging of the line or allow
linuxconf to generate word 'any' to satisfy with script
(which doesn't seem good - there will be an error message if
any of 'any' routes will be already set at this moment.

This problem seems to be more complex so this is simplest
way I think.
Comment 1 Michael K. Johnson 1999-11-18 13:15:59 EST
Have you tried initscripts-3.65?
Comment 2 Michael K. Johnson 1999-11-22 14:46:59 EST
Sorry, 3.65 was a typo for 4.65.
Comment 3 Milan Kerslager 1999-11-22 17:09:59 EST
My configuration seems to be OK with this update. Thanx a lot.

Note You need to log in before you can comment on or make changes to this bug.