Bug 543205 - [abrt] crash detected in pulseaudio-0.9.21-1.fc12 (malloc/segfault/udev)
Summary: [abrt] crash detected in pulseaudio-0.9.21-1.fc12 (malloc/segfault/udev)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ba9452ad15b10fb47afe2e0ad78...
: 550940 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-01 22:12 UTC by Austin Foxley
Modified: 2010-01-26 01:05 UTC (History)
4 users (show)

Fixed In Version: 0.9.21-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-13 16:27:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (9.26 KB, text/plain)
2009-12-01 22:12 UTC, Austin Foxley
no flags Details

Description Austin Foxley 2009-12-01 22:12:19 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Play music in rhythmbox
2. Start a bluetooth rfcomm session
3. watch PA crash

Attached file: backtrace
cmdline: /usr/bin/pulseaudio --start --log-target=syslog
component: pulseaudio
executable: /usr/bin/pulseaudio
kernel: 2.6.31.6-145.fc12.x86_64
package: pulseaudio-0.9.21-1.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Austin Foxley 2009-12-01 22:12:21 UTC
Created attachment 375214 [details]
File: backtrace

Comment 2 Matthias Clasen 2010-01-05 16:57:52 UTC
*** Bug 550940 has been marked as a duplicate of this bug. ***

Comment 3 Lennart Poettering 2010-01-08 22:52:53 UTC
Hmm, any chance you can reproduce this issue?

Comment 4 Austin Foxley 2010-01-12 16:35:36 UTC
Yes I can still reproduce this, although abrt didn't detect the crash this time, but audio still died, and I had to kill rhythmbox. I will try it some more.

Comment 5 Austin Foxley 2010-01-12 23:29:00 UTC
Happened again, and abrt caught it. It filed it as a duplicate of Bug 550940. I can dig up the stack trace if you want it (if the others are missing symbols or whatever).

This is with pulseaudio-0.9.21-2.fc12 now.

Comment 6 Lennart Poettering 2010-01-12 23:42:09 UTC
Hmm, by "reproducing" I meant that you can tell me the exact steps necessary to trigger the issue. Best would be if I could even reproduce this here with that guide.

Is there anything special on your setup? I.e. are you using BT audio, have you enabled any of the special features of PA, perhaps in paprefs? Do you run KDE?

Comment 7 Lennart Poettering 2010-01-12 23:43:25 UTC
OOps, I am an idiot, was thinking about a different bug when I wrote this. Ignore what I wrote in #6...

Comment 8 Lennart Poettering 2010-01-12 23:44:07 UTC
Though actually I would be interested in learning how I would set up an rfcomm session, so that I can reproduce the issue here locally.

Comment 9 Austin Foxley 2010-01-12 23:53:39 UTC
I'm an embedded developer and have a bluetooth virtual serial port on my hw, so I use rfcomm and minicom to talk to it. Example:

[austinf@peon ~]$ sudo rfcomm connect 0 10:00:E8:AD:0E:E2 1
Connected /dev/rfcomm0 to 10:00:E8:AD:0E:E2 on channel 1
Press CTRL-C for hangup

I don't use bluetooth audio.

PA dies every time I start up an rfcomm session it looks like, although it looks like it only dies, when it actually successfully sets up a session sucessfully. (i.e., you need hw).

FYI, A lot of phones have the Serial port BT profile

Comment 10 Lennart Poettering 2010-01-13 16:14:46 UTC
Ah, very good, I can reproduce the issue here, now. Now the question is how to fix this...

Comment 11 Lennart Poettering 2010-01-13 16:27:20 UTC
Ok, fixed this now upstream. Thanks. Will prepare a fresh upload for F12 soon.

http://git.0pointer.de/?p=pulseaudio.git;a=patch;h=4bcb1a909f936a63628273e7d35726bc64785eeb

Comment 12 Fedora Update System 2010-01-15 01:46:58 UTC
pulseaudio-0.9.21-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pulseaudio-0.9.21-3.fc12

Comment 13 Fedora Update System 2010-01-18 01:24:33 UTC
pulseaudio-0.9.21-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pulseaudio-0.9.21-4.fc12

Comment 14 Fedora Update System 2010-01-26 01:04:32 UTC
pulseaudio-0.9.21-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.