Bug 54327 - zgrep outputs empty lines
zgrep outputs empty lines
Status: CLOSED DUPLICATE of bug 43319
Product: Red Hat Linux
Classification: Retired
Component: gzip (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2001-10-04 08:17 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-04 08:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-04 08:17:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
When searching through a number of files for lines matching a pattern
(duh), zgrep outputs empty lines when no match is found

Version-Release number of selected component (if applicable):
RPM package: gzip-1.3-12, RH7.1

How reproducible:

Steps to Reproduce:
% cd /tmp
% echo "bla" > file
% echo "foo" > file2
% gzip file*
% zgrep blup file*

# In other words, the 2 empty lines between the prompts should not be there.
# For 2 files, this behaviour is not a disaster, for 100 files, it is,
# since found matches happily scroll off the top of the window.

Expected Results:  No output should be produced, since 'blup' is never
matched. In fact,

% gzip -d file*
% grep blup file*

does this (i.e. the prompt returns on the next line without outputting an
empty line)

Additional info:

zgrep behaved as grep (i.e. no output if no match) in R.H. 6.2

RPM package: gzip-1.3-12
Comment 1 Need Real Name 2001-10-04 08:26:48 EDT

*** This bug has been marked as a duplicate of 43319 ***

Note You need to log in before you can comment on or make changes to this bug.