Bug 543311 - gedit: symbol lookup error: gedit: undefined symbol: gtk_spinner_new
gedit: symbol lookup error: gedit: undefined symbol: gtk_spinner_new
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 529533
  Show dependency treegraph
 
Reported: 2009-12-02 00:48 EST by Rakesh Pandit
Modified: 2009-12-02 04:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 04:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rakesh Pandit 2009-12-02 00:48:21 EST
Description of problem:

gedit 2.29.3 does not start in rawhide

Version-Release number of selected component (if applicable):
gedit-2.29.3-2.fc13.i686.rpm

How reproducible:


Steps to Reproduce:
1. start gedit
2.
3.
  
Actual results:
gedit: symbol lookup error: gedit: undefined symbol: gtk_spinner_new

Expected results:
start

Additional info:

Thanks,
Comment 1 Rakesh Pandit 2009-12-02 00:51:40 EST
Prevents testing new gedit-plugins bug. Looking into this .. 

Regards,
Comment 2 Rakesh Pandit 2009-12-02 03:08:40 EST
I did a run and found prelink warnings and backtrace:

[ashu@dhcp1-96 ~]$ gdb gedit
[..]
(gdb) run
Starting program: /usr/bin/gedit 
[Thread debugging using libthread_db enabled]
warning: .dynamic section for "/usr/lib/libfam.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libudev.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
6
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x080b15a9 in build_tab_label (tab=<value optimized out>, nb=<value optimized out>) at gedit-notebook.c:926
#2  gedit_notebook_add_tab (tab=<value optimized out>, nb=<value optimized out>) at gedit-notebook.c:1004
#3  0x0809247f in gedit_window_create_tab (window=<value optimized out>, jump_to=<value optimized out>) at gedit-window.c:4027
#4  0x080672ac in main (argc=1, argv=0xbffff3c4) at gedit.c:727
(gdb)
Comment 3 Rakesh Pandit 2009-12-02 04:09:11 EST
Okay, problem is with

commit 3edb6ad18e6943c9fd22fdaa3675b77cc3fac30a
Author: Ignacio Casal Quinteiro <icq@gnome.org>
Date:   Thu Oct 29 17:41:25 2009 +0100

    Use GtkSpinner instead of GeditSpinner with gtk+ >= 2.19.0

It does not work well with < 2.19 gtk, even though patch should allow it to work.

Thanks,
Comment 4 Rakesh Pandit 2009-12-02 04:18:16 EST
Anyway ... as it is not going to effect rawhide, closing it.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.