This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 543483 - udev rename eth0 to Auto_Ethernet
udev rename eth0 to Auto_Ethernet
Status: CLOSED DUPLICATE of bug 557771
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 09:12 EST by Martin Naď
Modified: 2010-01-22 09:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 09:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg.old (36.00 KB, text/plain)
2009-12-24 15:44 EST, Martin Naď
no flags Details
dmesg (35.70 KB, text/plain)
2009-12-24 15:51 EST, Martin Naď
no flags Details
dmesg with udev ignore 70-persistent-net.rules (36.53 KB, text/plain)
2010-01-19 11:09 EST, Martin Naď
no flags Details
boot.log (741.74 KB, text/plain)
2010-01-19 11:47 EST, Martin Naď
no flags Details
messages.txt (3.44 MB, text/plain)
2010-01-19 11:49 EST, Martin Naď
no flags Details

  None (edit)
Description Martin Naď 2009-12-02 09:12:34 EST
Description of problem:
some after update kernel to kernel-2.6.31.6-157.fc12.x86_64 udev(or something other) rename eth0 to Auto_Ethernet and my network don`t work switch to old kernel maybe this fix(I am not sure becouse I not try envokes this) 

Version-Release number of selected component (if applicable):
 kernel-2.6.31.6-157.fc12.x86_64
udev-145-14.fc12.x86_64

Steps to Reproduce:
1.sorry this I don`t know 
2.
3.
  
Actual results:
network dont work becouse change name for eth0

Expected results:
avert to spontaneously rename eth*

Additional info:
Comment 1 Martin Naď 2009-12-02 09:31:06 EST
lspci
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)     ---eth0
04:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)  --eth1
Comment 2 Martin Naď 2009-12-02 17:00:52 EST
now change name to eht0 on new kernel
eht0      Link encap:Ethernet  HWadr 00:E0:7D:8A:01:6C
          inet adr:10.0.6.207  Všesměr:10.0.6.255 Maska:255.255.255.0
          inet6-adr: fe80::2e0:7dff:fe8a:16c/64 Rozsah:Linka
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ BĚŽÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:40610 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32176 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          RX bytes:38917095 (37.1 MiB)  TX bytes:5656554 (5.3 MiB)
          Přerušení:18 Vstupně/Výstupní port:0x6000
Comment 3 Martin Naď 2009-12-07 06:59:58 EST
and now sometimes udev want change name in boot but fail and system not start
Comment 4 Martin Naď 2009-12-07 07:27:07 EST
lsdev:

e100                         bc00-bc1f
eth1                     18
eth2                     23

lspci:
04:07.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 01)

04:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1) 

[namar@doma ~]$ ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:15:58:18:cb:d2 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:a0:c9:0f:a7:8f brd ff:ff:ff:ff:ff:ff
4: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:e0:7d:8a:01:6c brd ff:ff:ff:ff:ff:ff
Comment 5 Martin Naď 2009-12-24 15:44:23 EST
Created attachment 380235 [details]
dmesg.old
Comment 6 Martin Naď 2009-12-24 15:51:01 EST
Created attachment 380237 [details]
dmesg
Comment 7 Martin Naď 2009-12-26 03:23:13 EST
fail message on the start(it what I remember,becouse boot.log clean every start):

udev: udevd-work [341]: error changing netif name eth2 to _rename: File exist
Comment 8 Martin Naď 2009-12-26 03:27:27 EST
how I can log what udev doing?so that log is save after new start OS (udev.log.old etc)
Comment 9 Harald Hoyer 2010-01-05 09:10:40 EST
You might want to check and edit /etc/udev/rules.d/70-persistent-net.rules
Comment 10 Martin Naď 2010-01-05 14:14:20 EST
[root@doma ~]# cat /etc/udev/rules.d/70-persistent-net.rules2

# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# nVidia Corporation MCP51 Ethernet Controller (rule written by anaconda)
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rule written by anaconda)
# Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rule written by anaconda)
[root@doma ~]#



this is deufalt by the install
Comment 12 Martin Naď 2010-01-19 11:09:26 EST
Created attachment 385429 [details]
dmesg with udev ignore 70-persistent-net.rules

udev ignored my 70-persistent-net.rules
udev: renamed network interface eth2 to eth3
udev: renamed network interface eth1 to eth4
udev: renamed network interface eth0 to eth5

[namar@doma ~]$ cat /etc/udev/rules.d/70-persistent-net.rules

# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# nVidia Corporation MCP51 Ethernet Controller (rule written by anaconda)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:15:58:18:cb:d2", NAME="eth0"

# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rule written by anaconda)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:e0:7d:8a:01:6c", NAME="eth2"

# Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rule written by anaconda)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:a0:c9:0f:a7:8f", NAME="eth1"
[namar@doma ~]$
Comment 13 Martin Naď 2010-01-19 11:47:57 EST
Created attachment 385437 [details]
boot.log

I enable udev debug
Comment 14 Martin Naď 2010-01-19 11:49:46 EST
Created attachment 385438 [details]
messages.txt

udev_log="debug"
Comment 15 Martin Naď 2010-01-19 12:23:32 EST
it`s probably that I am wrong udev rules?
Comment 16 Harald Hoyer 2010-01-20 06:16:32 EST
also check your /etc/sysconfig/network-scripts/ifcfg-eth* files.
Comment 17 Martin Naď 2010-01-20 12:37:31 EST
ifcfg-eth* files is ok
Comment 18 Martin Naď 2010-01-22 09:35:00 EST
udev makeself rules and works

# PCI device 0x8086:0x1229 (e100)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:a0:c9:0f:a7:8f", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10de:0x0269 (forcedeth)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:15:58:18:cb:d2", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# PCI device 0x10ec:0x8139 (8139too)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:e0:7d:8a:01:6c", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"
Comment 19 Martin Naď 2010-01-22 09:52:14 EST

*** This bug has been marked as a duplicate of bug 557771 ***
Comment 20 Harald Hoyer 2010-01-22 09:54:10 EST
This is the reason /etc/udev/rules.d/70-persistent-net.rules exists..

Note You need to log in before you can comment on or make changes to this bug.