Bug 54351 - Rebuild attempt of php-4.0.6-8.src.rpm returns
Rebuild attempt of php-4.0.6-8.src.rpm returns
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 13:27 EDT by ctolley
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 17:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ctolley 2001-10-04 13:27:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Rebuilt the libxml2-2.4.5-1.src.rpm on my RH7.1 system, installed both the
resulting RPMs.  I then attempted to rebuild the php-4.0.6-8.src.rpm
against it.   During the various checks, I received the error "Please
reinstall the libxml >= 2.2.7 distribution" and the rebuild fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. On RH7.1 system, obtain and rebuild libxml2-2.4.5-1.src.rpm.
2. Install the resulting libxml2-2.4.5-1.i386.rpm and
libxml2-devel-2.4.5-1.i386.rpm.
3. After obtaining php-4.0.6-8.src.rpm, do: rpm --rebuild
php-4.0.6-8.src.rpm

	

Actual Results:  Rebuild fails with error "Please reinstall the libxml >=
2.2.7 distribution"

Expected Results:  PHP should have found the libxml2 libraries in their
default locations and compiled without error.

Additional info:

I opened another bug report (54301) and was told that php needed to be
using the xml2-config that is provided by the libxml2 package.  I unrolled
the SRPM for php and grep'd all the files (including the spec) for
"xml2-config" but found no reference.

Earlier, in an effort to fix this, I patched libxml2 to install in
/usr/include/libxml instead of /usr/include/libxml2/libxml, but was told
the original installation was not a bug, but a feature, and that php must
find its compile-time parameters from xml2-config.

I'm at a loss as to how to make this work.  With my "patched" version of
libxml2, php rebuilds with zero errors, but as this doesn't match any of
your provided SRPMs, something else must be wrong.
Comment 1 Phil Copeland 2002-01-08 12:55:43 EST
hummm
I think I fixed that in the rawhide version 

ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/php-4.0.6-13.src.rpm

try building with that, tell me if that works for you

Phil
=--=


Comment 2 ctolley 2002-01-10 17:11:29 EST
Worked fine.  Thanks for looking into this.
Comment 3 Phil Copeland 2002-01-10 19:51:45 EST
Excellent dead bug 8)
closed...

Note You need to log in before you can comment on or make changes to this bug.