Bug 54362 - Anaconda terminates installation showing me an ImportError
Anaconda terminates installation showing me an ImportError
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-04 15:16 EDT by Milos Kral Jr
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-25 10:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Milos Kral Jr 2001-10-04 15:16:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
After I boot from the CD, I select a normal installation and Anaconda 
begins to runs.
Its gives a kill command and terminates the installation telling me it is 
safe to reboot the system.
This is the only error I can find.
ImportError: /usr/lib/libcrypto.so.1: undefined symbol: 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot From CD
2. Select Normal Install

Actual Results:  Same error as mentioned above

Expected Results:  Linux installing properly

Additional info:

I have tryied the Anaconda Errata update disk I found on your site, but it 
didn't help.
Comment 1 Brent Fox 2001-10-04 15:43:13 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 2 Milos Kral Jr 2001-10-04 15:59:32 EDT
No change, still get the same error and termination/kill.
Comment 3 Brent Fox 2001-10-04 16:05:53 EDT
When the crash occurs, can you press <Ctrl><Alt><F4> and see if there are any
error messages?
Comment 4 Milos Kral Jr 2001-10-04 16:14:55 EDT
No error message
Its just tells me my USB mouse was detected and installed.
Comment 5 Brent Fox 2001-10-04 16:19:47 EDT
Weird.  Are these cd's that you burned yourself?  If so, did you verify the
md5sums of the ISO's before burning them?
Comment 6 Milos Kral Jr 2001-10-04 16:22:47 EDT
No, and I already deleted the images... DAMN
Yes, They are burned.
Always a possibility of bad burns, but I wanted to see if there were other 
Any other ideas?

Comment 7 Brent Fox 2001-10-04 16:29:21 EDT
Well, this is the only thing I can think of.  The installer is looking for files
(a library in this case) and is having trouble doing this.  I can't say for sure
that the cd is the problem, but it sounds like it to me.  I haven't seen this
particular problem in all of my testing.  Usually when the installer has trouble
pulling files from the cd, it's a bad cd.

Do you think you could redownload cd #1?  Like I said, I'm not 100% certain this
is the problem, but it seems likely.
Comment 8 Milos Kral Jr 2001-10-04 16:31:35 EDT
Downloading CD1 as we speak. getting 300k. I'll check the MD5 sums after and 
burn it. I'll post after I try that
Comment 9 Brent Fox 2001-10-04 17:09:32 EDT
Comment 10 Milos Kral Jr 2001-10-04 17:27:32 EDT
Where do I get the CD checksums?
Comment 11 Brent Fox 2001-10-04 18:56:22 EDT
In the MD5SUM file on the FTP site.
For 7.1, the contents are:

edc2d5e1ab6093e3d486cc38dc12511a  seawolf-i386-SRPMS.iso
596b1575773e88e066326f6741312a6f  seawolf-i386-disc1.iso
f27b912299572a542cd663b712444445  seawolf-i386-disc2.iso
59f3333435378fb1645700731c91bc54  seawolf-i386-powertools.iso
Comment 12 Milos Kral Jr 2001-10-05 11:31:48 EDT
I have downloaded the Disk1 ISO 5 times now, and the checksums NEVER match.
I've tried downloading it just from ftp.redhat.com with bulletproof FTP, using 
getright, downloading it from other sites... but the checksums never match.
Any ideas?
Comment 13 Brent Fox 2001-10-05 11:54:24 EDT
Hmmm...I don't know.  I'm not familiar with bulletproof FTP, but have you made
sure that the transfer mode is set to binary?  You probably have, but that's the
only thing I can think of.  You could try just downloading the bootnet.img file
from the /images directory, make a boot floppy from it, and then doing an FTP
based install from the web....  Other than that, I'm out of ideas.
Comment 14 Milos Kral Jr 2001-10-07 17:22:43 EDT
Actually, The transfer mode was set to Auto, Which could be ANCI or Binary...

I'll try to redownload it under BINARY only mode and let you know.
Comment 15 Brent Fox 2001-10-15 17:41:13 EDT
Yes, I have seen some FTP clients get confused and do ASCII mode sometimes when
they should have done binary.  Let me know how it turns out.
Comment 16 Brent Fox 2001-10-25 10:40:10 EDT
Any more info here?
Comment 17 Brent Fox 2001-11-05 10:04:34 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.