Bug 543628 - Availability on Graph View incorrectly calculated
Availability on Graph View incorrectly calculated
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
unspecified
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-12-02 13:40 EST by Rodrigo A B Freire
Modified: 2010-09-13 16:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 16:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rodrigo A B Freire 2009-12-02 13:40:18 EST
Description of problem:
The Availability on the Monitor - "Graph" view is incorrectly calculated.

Version-Release number of selected component (if applicable):
JON 2.3.0GA, JON 2.2.0GA

How reproducible:
Tested on various JON servers and all of them showed the same behavior.

Steps to Reproduce:
1. On any monitorable resource, select the "Monitor" tab
2. Click the "Availability" view
3. Notice the "Availability" value.
3.1 At the bottom of the screen, roll to the last page (in the index 1, 2, 3 etc) and write down the first date of collected metric
4. Click the "Graphs" View
5. On the timespan selector on the bottom of the screen, select "Advanced Settings"
6. Select "Within a date range" and in the From: field select the date you recorded on the step 3.1
7. On the To: field, select the actual date & time
8. Plot the graph and read the "Availability" value
  
Actual results:
The values doesn't match

Expected results:
Matched values

Additional info:
Looks like the metrics are calculated using the red/green buckets/dots in the "Graphs" view instead of doing some more elaborated calc that's performed on "Availability" View.
Comment 1 wes hayutin 2010-02-16 11:59:32 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 12:04:41 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 wes hayutin 2010-02-16 16:08:08 EST
Mass move to component= Monitoring
Comment 4 Corey Welton 2010-09-13 16:04:11 EDT
closing per gwt work

Note You need to log in before you can comment on or make changes to this bug.