Bug 54366 - Can't add users in anaconda --reconfig
Can't add users in anaconda --reconfig
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 17:41 EDT by John A. Hull
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 15:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John A. Hull 2001-10-04 17:41:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

Description of problem:
In the Add User window in anaconda --reconfig, you can only access the OK 
or Back button; you cannot tab into the fields to add a user.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run anaconda --reconfig
2. Proceed to the Add User screen
3.
	

Actual Results:  Can't add a user

Expected Results:  Ability to add a user

Additional info:
Comment 1 Brent Fox 2001-10-05 12:07:35 EDT
Yes, this was intentional.  After having done the installation, it is better to
use redhat-config-users to add, modify, and remove users.
Comment 2 John A. Hull 2001-10-05 12:28:43 EDT
If that's the case, then just removing the screen altogether might be the best 
solution.
Comment 3 Brent Fox 2001-10-05 12:49:10 EDT
If you are talking about the graphical installer, we felt that it was important
to allow the root password to be changed.  Since that is on the same screen,
skipping the screen would prevent that.  The text mode installer has the root
password and user accounts on separate screens, so perhaps that would be
possible there.
Comment 4 John A. Hull 2001-10-05 14:04:48 EDT
Yes, I was referring to the text version of anaconda. At Dell, our factory-
install of RHL 7.2 kicks the users into the text anaconda --reconfig on first 
system boot to configure their language, keyboard type, etc. right away so that 
we don't have to try to guess what they're going to use. So the customer is 
going to get a screen automatically that they can't use. No big deal, but it's 
better just not to have the screen show up at all.
Comment 5 Michael Fulbright 2001-10-11 11:07:31 EDT
We are leaning towards replacing reconfig mode with a 'first boot' harness to
allow more flexible customization of the first boot environment. We're going to
remove reconfig from the installer when the replacement is ready.
Comment 6 Brent Fox 2002-01-20 14:22:04 EST
Yes, this will be fixed by firstboot.  Marking as 'wontfix' for anaconda, but
this will be fixed by a different program.

Note You need to log in before you can comment on or make changes to this bug.