Bug 543752 - [abrt] crash detected in moblin-panel-people-0.0.10-1.fc12
Summary: [abrt] crash detected in moblin-panel-people-0.0.10-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: moblin-panel-people
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cee4d0f78e76279a525e70f66cb...
: 539771 544445 548610 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-03 00:42 UTC by Jon Burgess
Modified: 2009-12-18 09:52 UTC (History)
4 users (show)

Fixed In Version: 0.2.0-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-10 04:25:31 UTC


Attachments (Terms of Use)
File: backtrace (14.76 KB, text/plain)
2009-12-03 00:42 UTC, Jon Burgess
no flags Details
unref self_contact iff e_contact_get() succeeds (661 bytes, patch)
2009-12-05 22:55 UTC, Jon Burgess
no flags Details | Diff

Description Jon Burgess 2009-12-03 00:42:13 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. The people icon never even appears on the menu bar. I guess it crashes during startup
2.
3.

Comment: I think it used to appear until I updated to this version of moblin-panel-people
Attached file: backtrace
cmdline: /usr/libexec/moblin-panel-people
component: moblin-panel-people
executable: /usr/libexec/moblin-panel-people
kernel: 2.6.31.6-145.fc12.i686
package: moblin-panel-people-0.0.10-1.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Jon Burgess 2009-12-03 00:42:16 UTC
Created attachment 375636 [details]
File: backtrace

Comment 2 Jon Burgess 2009-12-03 00:46:08 UTC
Here are the messages from the .xsession log

[jburgess@e901 ~]$ grep people .xsession-errors
** (moblin-panel-people:2187): DEBUG: Setting up toolbar proxy
** (moblin-panel-people:2187): DEBUG: Unable to create proxy for /org/moblin/UX/Shell/Toolbar: Could not get owner of name 'org.moblin.UX.Shell.Toolbar': no such name
Window manager warning: Log level 128: Found dbus name org.moblin.UX.Shell.Panels.people
Window manager warning: Log level 128: Creating proxy for org.moblin.UX.Shell.Panels.people, 0x9c1e520
** (moblin-panel-people:2187): WARNING **: anerley-ebook-feed.c:139: Error getting self contact: e_book_get_self: there was no self contact UID stored in gconf
Window manager warning: Log level 128: Panel service [people] is not running, starting.

Comment 3 Peter Robinson 2009-12-03 05:47:03 UTC
*** Bug 539771 has been marked as a duplicate of this bug. ***

Comment 4 Peter Robinson 2009-12-05 22:20:22 UTC
*** Bug 544445 has been marked as a duplicate of this bug. ***

Comment 5 Jon Burgess 2009-12-05 22:55:11 UTC
Created attachment 376374 [details]
unref self_contact iff e_contact_get() succeeds

I took a look at the code and it looks like the code is incorrectly handling the error path. If the e_contact_get() fails then the self_contact is not valid and should not be unref'd.

Comment 6 Jon Burgess 2009-12-05 22:58:16 UTC
This appears to be already fixed in the anerly master tree:
http://git.moblin.org/cgit.cgi/anerley/commit/?id=e604bdf50e2b05ed6977564ea8d6aac948af0e03

Comment 7 Fedora Update System 2009-12-07 01:24:14 UTC
anerley-0.2.0-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/anerley-0.2.0-4.fc12

Comment 8 Peter Robinson 2009-12-07 02:43:27 UTC
(In reply to comment #6)
> This appears to be already fixed in the anerly master tree:

Thanks Jon, I didn't pick this up. Your help is very much appreciated!

Comment 9 Fedora Update System 2009-12-08 07:44:46 UTC
anerley-0.2.0-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anerley'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12879

Comment 10 Fedora Update System 2009-12-10 04:25:26 UTC
anerley-0.2.0-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Peter Robinson 2009-12-18 09:52:34 UTC
*** Bug 548610 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.