Bug 54376 - Setup fails on upgrade with OSError [Errno 2]
Setup fails on upgrade with OSError [Errno 2]
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 01:02 EDT by Mike Painter
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-05 21:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (10.49 KB, text/plain)
2001-10-05 01:07 EDT, Mike Painter
no flags Details

  None (edit)
Description Mike Painter 2001-10-05 01:02:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When booting from RH 7.1 CDRom and running default installation on AMDK6-2 
550 on AOpen AX59Pro MB. 256MB PC133 2 IDE disks in Fat32, 1 4.5GB SCSI at 
SDA on Adaptec 2940UW.  Choosing upgrade from install menu, setup finds 
existing RH6.2 installation on SDA6.  After enabling swap successfully, 
setup fails with OSError [Errno 2]

Version-Release number of selected component (if applicable):anaconda


How reproducible:
Always

Steps to Reproduce:
1.Boot from RH7.1 Install CDRom disk 1, choose boot.
2.Run upgrade an existing installation.
3.Let setup create additional swap space (258MB recommended)

	

Actual Results:  Setup fails with file not found OSERROR [Errno 2]

Expected Results:  Setup to continue and do a successful upgrade of a 
previously working RH 6.2 installation.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 391, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 879, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 481, in 
nextClicked
    next = self.currentScreen.getNext ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/upgrade_swap_gui.py", 
line 78, in getNext
    self.todo.upgradeFindPackages()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1240, in 
upgradeFindPackages
    iutil.rmrf (self.instPath + "/var/lib/anaconda-rebuilddb"
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 294, in 
rmrf
    files = oslistdir .(path)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
path: /mnt/sysimage/var/lib/anaconda-rebuilddb1002229760
Comment 1 Mike Painter 2001-10-05 01:07:42 EDT
Created attachment 33438 [details]
anaconda dump
Comment 2 Brent Fox 2001-10-05 11:35:12 EDT
Can you boot into your 6.2 system and run 'rpm --rebuilddb' as root?  Then try
the upgrade again and see if that fixes the problem.  I think that there may be
some inconsistency in your RPM database, and running 'rpm --rebuilddb' should
fix any problems that might exist.

BTW, this looks like a dupe of bug #37099.
Comment 3 Mike Painter 2001-10-05 21:43:32 EDT
I would do that, but now I have changed SCSI cards and can no longer boot 
directly into that installation.  I see how it could be a RPM dbase problem.
I think I will follow the advice in #37099, or I can just do a clean install of 
7.1 as well. Thanks for the help. Sorry I did not find the other bug report, it 
did not show up in my search.
Comment 4 Brent Fox 2001-10-15 12:26:51 EDT
Ok.  I'm going to close the bug now, but feel free to add more information if
you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.