Bug 54391 - Spellchecking in emacs with aspell on tex document fails
Spellchecking in emacs with aspell on tex document fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 12:15 EDT by Richard Smemoe
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 02:50:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Emacs error log (317 bytes, text/plain)
2001-10-05 14:14 EDT, Richard Smemoe
no flags Details
tex document that fails when spell checking (55.31 KB, text/plain)
2001-10-05 14:15 EDT, Richard Smemoe
no flags Details

  None (edit)
Description Richard Smemoe 2001-10-05 12:15:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When I try to spell check in graphical emacs(Edit->Spell->Check Buffer) on
a tex document, it works for a while, then gives the attached error and
stops spell checking.  This happens on several different tex documents.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run emacs p3.tex (p3.tex is attached)
2. Choose Edit->Spell->Check Buffer(Help->Options->Debug on Error will give
you error output)
3. Hit space to go through the document.  Spell-checking will eventually
stop and give the error if you have debug on error selected
	

Actual Results:  It gives me the attached error message

Expected Results:  The document should of finished getting spell-checked

Additional info:
Comment 1 Richard Smemoe 2001-10-05 14:14:22 EDT
Created attachment 33498 [details]
Emacs error log
Comment 2 Richard Smemoe 2001-10-05 14:15:17 EDT
Created attachment 33499 [details]
tex document that fails when spell checking
Comment 3 Trond Eivind Glomsrxd 2001-10-08 12:20:45 EDT
I can reproduce it...
Comment 4 Trond Eivind Glomsrxd 2001-10-08 12:36:17 EDT
Still a problem with ispell.el 3.5 from
http://www.kdstevens.com/~stevens/ispell-page.html
Comment 5 Tor Andre Myrvoll 2001-10-19 10:51:18 EDT
I have the same problem. Here's my setup:

Red Hat Linux release 7.1.94 (Roswell)
GNU Emacs 20.7.1
@(#) International Ispell Version 3.1.20 (but really Aspell .33.7 alpha)

I can submit my TeX document if there's any need for it.
Comment 6 Aaron VanDevender 2002-05-16 13:52:18 EDT
I get a similar "Ispell Misalignment Error" when spell checking tex documents
using emacs 21.2-2 (included in RH 7.3) and aspell 0.33.7.1. Downgrading to
emacs 20.7-41 fixes the problem. I also notice another behavoir while spell
checking tex documents with emacs 21.2-2, which is whenever a "% LocalWords:
..." line is present at the bottom the document, emacs doesn't even begin to
check the document as it had before, but instead emacs locks up, takes up 100%
of the CPU, and has to be killed.

The LocalWords tagline is a tex comment which emacs recognizes to be a document
specific addendum to the user spelling dictionary.
Comment 7 Jens Petersen 2002-10-30 17:25:01 EST
This problem still occurs with the emacs in RHL 8.0.
Comment 8 Jens Petersen 2003-01-15 10:19:22 EST
I don't seem able to reproduce this any longer.
Could you try testing with the latest emacs and aspell
in rawhide?
Comment 9 Kostas Georgiou 2003-01-17 05:26:01 EST
emacs-21.2-25 (phoebe) and emacs-21.2-29 (rawhide) still have the problem with
the      submitted attachment. I then upgraded aspell-0.33.7.1-20 and
pspell-0.12.2-15 (pheobe/rawhide) and it still fails. Which versions of
emacs/aspell you used ? 
Comment 10 Aaron VanDevender 2003-01-23 09:22:18 EST
I just tried it with:
emacs-21.2-29
aspell-0.33.7.1-20
pspell-0.12.2-15

and did not see the error. i tried it with the attached file (p3.tex) and with
some of my own.
Comment 11 Jens Petersen 2003-05-20 03:24:14 EDT
I still can't reproduce with 21.3.
Comment 12 Jens Petersen 2004-01-14 02:50:34 EST
Closing.  Please re-open if you can reproduce with 21.3.

Note You need to log in before you can comment on or make changes to this bug.