Bug 54405 - all port numbers above 32768 erroneously report
all port numbers above 32768 erroneously report
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-06 01:34 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-06 01:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-06 01:34:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0; DigExt)

Description of problem:
Works fine in 6.1, but now in 7.1
ftp -i 123.123.123.123 50000
gives that error message.

I think someone must have messed with the code, and accidentally change 
the data type to "signed int" - beats me *why* anyone would be messing 
with this, and make such a silly mistake, and it would get past the 
quality control test suite... there *is* a quality-control test suite, 
isn't there?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ftp -i 123.123.123.123 50000
	

Actual Results:  123.123.123.123.: bad port number-- 50000

Expected Results:  connected to my ftp server which runs on port 50000

Additional info:

works fine in RedHat 6.1.

Possible security implications:
1. Why did it get changed such that it got broken?  perhaps a diff of the 
6.1 and 7.1 source should be examined for other messups?
2. Since this paramater is obviously not being checked proplery, is there 
something here, or new, that could lead to a buffer problem?
Comment 1 Bernhard Rosenkraenzer 2001-10-23 10:45:10 EDT
I can't reproduce this on a 7.2 system
(ftp-0.17-12).

[bero@spock bero]$ ftp localhost 50000
Connected to localhost (127.0.0.1).
220 spock.home.bero.org FTP server (Version wu-2.6.1-18) ready.
Name (localhost:root):

Comment 2 Bernhard Rosenkraenzer 2001-10-23 10:46:06 EDT
(and yes, there is a QA test suite. But it didn't check for this. It just does 
a couple of standard ftp transfers, port 21)

Note You need to log in before you can comment on or make changes to this bug.