Bug 54410 - No X windows on start
No X windows on start
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-10-06 10:50 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-01 16:39:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-06 10:50:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Upgrading from 7.1 to Roswell. Do complete new install.  Configure 
intitially for Dell 1280L monitor and Matrox Millenium 4M video card. 
Accept default screen resolution.  On completion of system load, XFree 
attempts to start, and attempts, and attempts .....etc forever.  Start 
system in text mode...go to Xconfigurator, configure for 1024x768 16 bit 
mode. Test, everything cool and groovy.  Create  config file. Restart, no 
graphics mode.  System worked fine with both 1024x768 and 1280x1024 in 
7.1 release.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
2.configure X

Actual Results:  No KDE desktop, no GNOME desktop.  Text mode only

Expected Results:  Should have graphic interface (KDE in this case)

Additional info:
Comment 1 Need Real Name 2001-10-07 03:54:26 EDT
I hope this is in the right place - I've never done this before!

I have exactly the same problem with sis630 integrated video - have done a 
fresh install of roswell 3 times, always with the same result. 

The error given out by the X server is

Fatal Server error:
could not open default font 'fixed'
XIO:  fatal IO error 104 (Connection reset by peer) on Xserver ":0.0" after 0 
requests (0 known processed) with 0 events remaining.

This machine was running Xfree 4.1 before the upgrade so it *will* work.  

Newsflash!  X is linked to XF86_SVGA when it installs ...
Hey, I relinked it to XFree86 and it now works fine!!

Hope this helps
Comment 2 Need Real Name 2001-10-07 08:49:22 EDT
At the risk of sounding really stupid (according to my wife not unusual), if 
relinking it to XFree86 will work, how do I do it (I'm a MS person exploring 
the possibilities).
Comment 3 Mike A. Harris 2001-10-11 15:13:39 EDT
I presume both of you are using the 3.3.6 server.  This problem has
been fixed in XFree86 4.1.0-3.  Please upgrade.
Comment 4 Need Real Name 2001-10-11 18:07:31 EDT
Already running XFree 4.1...the problem is in the Roswell Beta.  I managed to 
make the system work by removing the Matrox video card, substuting a cheapie 
video card, restarting, running Kudzu, shutting down, replacing the Matrox and 
setting the video resolution on restart....a long way to get to X...

Note You need to log in before you can comment on or make changes to this bug.