This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 544141 - programlisting has extra top and bottom white space added
programlisting has extra top and bottom white space added
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-03 20:08 EST by Jeff Fearn
Modified: 2010-11-23 23:20 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.3-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 23:15:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example of fixed PDF output (34.23 KB, image/png)
2009-12-03 20:39 EST, Jeff Fearn
no flags Details

  None (edit)
Description Jeff Fearn 2009-12-03 20:08:05 EST
Description of problem:
When programlisting has syntax highlighting applied and extra line is added to the top and the bottom. This looks odd in small code samples.

Version-Release number of selected component (if applicable):
1.2

How reproducible:
Always.

Steps to Reproduce:
1. write a programlisting
2. set language attribute
3. compile
  
Actual results:
Highlighted code block, with added top and bottom white space.

Expected results:
Highlighted code block, with white space that matches source.

Additional info:
This is due to an extra block level being added during the highlight process.
Comment 1 Jeff Fearn 2009-12-03 20:12:30 EST
Re-factored method for structuring highlighted content.
Comment 2 Jeff Fearn 2009-12-03 20:39:34 EST
Created attachment 375976 [details]
example of fixed PDF output
Comment 3 Fedora Update System 2009-12-07 21:15:26 EST
publican-1.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc12
Comment 4 Fedora Update System 2009-12-07 21:18:45 EST
publican-1.3-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc11
Comment 5 Fedora Update System 2009-12-09 23:14:21 EST
publican-1.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-12-09 23:27:12 EST
publican-1.3-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.