Bug 54415 - gdialog missing from gnome-utils
Summary: gdialog missing from gnome-utils
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-utils   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-06 18:29 UTC by nboric
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-03 21:19:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nboric 2001-10-06 18:29:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [es] (X11; U; Linux 2.4.7-6 i686)

Description of problem:
That's it, gdialog isn't included in gnome-utils package, as it should
(it's in the official gnome tarball, it was included in redhat 7, and it's
included in ximian gnome) Why isn't it in roswell?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
in a bash script:
FILE=$(gdialog --title "Comprimir" --inputbox "Name..." 200 350 $1 2>&1)

Actual Results:  bash: gdialog: command not found

Expected Results:  a dialog to write in a name

Additional info:

rpm -qil gnome-utils

Name        : gnome-utils                  Relocations: (not relocateable)
Version     : 1.4.0                             Vendor: Red Hat, Inc.
Release     : 4                             Build Date: lun 27 ago 2001
18:24:47 CLT
Install date: vie 21 sep 2001 18:27:50 CLT      Build Host:
stripples.devel.redhat.com
Group       : Applications/System           Source RPM:
gnome-utils-1.4.0-4.src.rpm
Size        : 3359571                          License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.gnome.org
Summary     : GNOME utility programs.
Description :
GNOME (GNU Network Object Model Environment) is a user-friendly set of
GUI applications and desktop tools to be used in conjunction with a
window manager for the X Window System. The gnome-utils package
includes a set of utilities for GNOME, including Gcalc, Gdialog,
Gdiskfree, and many others.
/usr/bin/gcalc
/usr/bin/gcharmap
/usr/bin/gcolorsel
/usr/bin/gdict
/usr/bin/gfloppy
/usr/bin/gfontsel
/usr/bin/gless
/usr/bin/gsearchtool
/usr/bin/gtt
/usr/bin/guname
/usr/share/doc/gnome-utils-1.4.0
/usr/share/doc/gnome-utils-1.4.0/AUTHORS
/usr/share/doc/gnome-utils-1.4.0/COPYING
/usr/share/doc/gnome-utils-1.4.0/ChangeLog
/usr/share/doc/gnome-utils-1.4.0/NEWS
[...] etc

As you can see, gdialog isn't there, but the description says it should

Comment 1 Havoc Pennington 2001-10-08 15:46:15 UTC
The description is incorrect; a number of gnome-utils programs were removed due
to not working very well, not being maintained, not being useful, etc.
Description should be fixed. If gdialog seems to be maintained/working these
days we could review it and consider putting it back.

Comment 2 W. Michael Petullo 2002-03-03 21:19:06 UTC
Gdialog works fine for me.  I have been using the version included in Ximian's
gnome-utils-1.4.0-ximian.10 RPM.  Gdialog is very useful when writing Naultilus
scripts.  For example, I wrote a search and replace script that, when installed
in ~/.gnome/nautilus-scripts, allows a user to select several files, right click
on them, and perform a search and replace on them.  I would like to see gdialog
it back in Red Hat' gnome-utils package -- it can really add some power and
user-friendliness to GNOME and Nautilus scripts.

Comment 3 Havoc Pennington 2002-03-05 21:08:22 UTC
Should be in 1.4.0-8


Note You need to log in before you can comment on or make changes to this bug.