This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54417 - rpm hangs on erasing/installing
rpm hangs on erasing/installing
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-06 16:47 EDT by Michele Baldessari
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-08 11:23:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Gzip of the strace on the rpm command that hung (42.59 KB, application/octet-stream)
2001-10-06 16:54 EDT, Michele Baldessari
no flags Details

  None (edit)
Description Michele Baldessari 2001-10-06 16:47:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010924

Description of problem:
Probably duplicate of the closed bug (#50933). When uninstalling e few rpms
"rpm -e file.rpm" simply hangs. I will attach straces shortly.
rpm version : rpm-4.0.3-1.03
System had quite a lot installations/deinstallations/rebuildings of
[custom] rpms. 
After an "rpm --rebuilddb" the hang disappears
It all happens quite sporadically so I am not able to reproduce it often
(happened only on installing or erasing)

Version-Release number of selected component (if applicable):
4.0.3-1.03

How reproducible:
Sometimes

Steps to Reproduce:
1. rpm -e bonobo-conf bonobo-conf-devel evolution
2. (program never ends)
3.


Actual Results:  rpm hangs

Expected Results:  Finish the install/deletion :)

Additional info:
Comment 1 Michele Baldessari 2001-10-06 16:54:23 EDT
Created attachment 33538 [details]
Gzip of the strace on the rpm command that hung
Comment 2 Bill Nottingham 2001-10-08 11:23:35 EDT
rm -f /var/lib/rpm/__db*

should fix it.
Comment 3 Jeff Johnson 2001-11-05 13:56:35 EST
This problem appears solved.

Note You need to log in before you can comment on or make changes to this bug.