Bug 544218 - [abrt] crash in psp::PrintFontManager::analyzeTrueTypeFamilyName
Summary: [abrt] crash in psp::PrintFontManager::analyzeTrueTypeFamilyName
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9a845e09ea8f2afd6aaa59d3fcd...
: 551414 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-04 09:26 UTC by Charles Liu
Modified: 2010-02-16 13:04 UTC (History)
4 users (show)

Fixed In Version: 3.1.1-19.26.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-16 13:04:44 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (13.37 KB, text/plain)
2009-12-04 09:26 UTC, Charles Liu
no flags Details
File: cmdline (314 bytes, text/plain)
2009-12-04 09:26 UTC, Charles Liu
no flags Details
strace -f /usr/lib/openoffice.org3/program/soffice.bin -writer > /tmp/strace.log 2>&1 (220.87 KB, application/x-gzip)
2009-12-05 07:59 UTC, Charles Liu
no flags Details
fc-list -v (761.96 KB, text/plain)
2009-12-09 00:58 UTC, Charles Liu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenOffice.org 107552 0 None None None Never

Description Charles Liu 2009-12-04 09:26:48 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///media/449CB2E49CB2CFA2/work/DEV/manual/%E6%96%B0%E5%B7%A5%E7%A8%8B%E5%B8%88%E5%85%A5%E8%81%8C%E8%B5%84%E6%96%99/Sina%20%E9%80%9A%E9%81%93%E6%9C%8D%E5%8A%A1%E5%99%A8%E4%BD%BF%E7%94%A8%E6%8C%87%E5%8D%97%EF%BC%88%E7%94%A8%E6%88%B7%E7%89%88%EF%BC%89v1.3.doc
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.31.6-145.fc12.i686
package: openoffice.org-writer-1:3.1.1-19.14.fc12
rating: 3
reason: Process was terminated by signal 11

Comment 1 Charles Liu 2009-12-04 09:26:51 UTC
Created attachment 376032 [details]
File: backtrace

Comment 2 Charles Liu 2009-12-04 09:26:54 UTC
Created attachment 376033 [details]
File: cmdline

Comment 3 Caolan McNamara 2009-12-04 09:44:47 UTC
This is a crash on trying to parse a particular truetype font. I'd *really* like to find out what font it is, and get the font file if possible. 

I would guess that this happens on every start-up of OpenOffice.org ? If so could you attach the output of

strace -f /usr/lib/openoffice.org3/program/soffice.bin -writer > /tmp/strace.log 2>&1

and we'll try and find out which .ttf is the last one to be opened up before the crash

Comment 4 Charles Liu 2009-12-05 07:59:26 UTC
Created attachment 376285 [details]
strace -f /usr/lib/openoffice.org3/program/soffice.bin -writer > /tmp/strace.log 2>&1

i think it might be some MS fonts, cuz the file i opened was created by my company where most the guys use MS windows.

Comment 5 Caolan McNamara 2009-12-07 10:19:49 UTC
The initial backtrace suggested that OOo crashed quite early, while the strace above suggests that OOo didn't crash during the strace. I was rather hoping to see OOo opening a particular font file and then the strace to end, indicating that a particular font file was causing it to crash. I feel something changed between the time of the crash, and the strace :-(

I can see see that there are some fonts in ~/.fonts and I uploaded the contents of a stock winxp c:\windows\fonts dir to my own .fonts, but without a crash here locally when I forced OOo to open the lot of them. 

Perhaps you've got some fonts that I don't, and one of them was set to the default application font at one stage, but no longer is. 

So... could you attach the output of

fc-list -v > /tmp/all.font.info

and I'll look through it to see if there is some font in there that I don't have which might help me reproduce it.

Comment 6 Charles Liu 2009-12-09 00:58:37 UTC
Created attachment 377074 [details]
 fc-list -v

Comment 7 Caolan McNamara 2009-12-09 09:41:57 UTC
Score, Aquabase-spanish-support.ttf is probably the offender. I can reproduce this now that I got this from https://sourceforge.net/projects/mac4lin/files/

Comment 8 Caolan McNamara 2009-12-09 10:31:09 UTC
Fix checked in and supplied upstream.
Quick fix is to remove ~/.fonts/Aquabase-spanish-support.ttf
OOo-side fix will be in >= 3.1.1-19.21

Comment 9 Charles Liu 2009-12-09 10:49:04 UTC
interesting, this is basically the first time i report a bug and see it resolved for the whole process. 
many thanks to caolanm@redhat.com

Comment 10 Fedora Update System 2009-12-10 09:03:56 UTC
openoffice.org-3.1.1-19.21.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.21.fc12

Comment 11 Fedora Update System 2009-12-11 18:16:02 UTC
openoffice.org-3.1.1-19.21.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13052

Comment 12 Fedora Update System 2009-12-17 08:58:00 UTC
openoffice.org-3.1.1-19.22.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.22.fc12

Comment 13 Fedora Update System 2009-12-18 04:25:36 UTC
openoffice.org-3.1.1-19.22.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13297

Comment 14 David Tardon 2009-12-30 15:50:02 UTC
*** Bug 551414 has been marked as a duplicate of this bug. ***

Comment 15 kwanbis 2009-12-30 16:03:51 UTC
Same issue here. It was solved by just renaming the TTF.

Thanks!

Comment 16 Fedora Update System 2010-02-03 09:16:06 UTC
openoffice.org-3.1.1-19.25.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.25.fc12

Comment 17 Fedora Update System 2010-02-05 01:27:49 UTC
openoffice.org-3.1.1-19.25.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1460

Comment 18 Fedora Update System 2010-02-13 12:00:11 UTC
openoffice.org-3.1.1-19.26.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.26.fc12

Comment 19 Fedora Update System 2010-02-16 13:02:40 UTC
openoffice.org-3.1.1-19.26.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.