Bug 544372 - squirrlemail spell checking fails with an error
Summary: squirrlemail spell checking fails with an error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-04 18:36 UTC by Kevin Fenzi
Modified: 2009-12-10 04:27 UTC (History)
2 users (show)

Fixed In Version: 1.2.8-13.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-10 04:27:49 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2009-12-04 18:36:02 UTC
squirrelmail-1.4.20-0.rc2.20090917.fc12.noarch

Trying to spell check an email results in an error window with: 

"I tried to execute 'hunspell -a', but it returned:

@(#) International Ispell Version 3.2.06 (but really Hunspell 1.2.8)"

hunspell is installed and running 'hunspell -a' does show the above comment line.

Comment 1 Michal Hlavinka 2009-12-07 16:27:23 UTC
I can reproduce this, thanks for the report

Comment 2 Michal Hlavinka 2009-12-08 13:22:23 UTC
Well, it seems, it caused by hunspell. I've checked aspell/ispell and both works, only hunspell is broken, because it segfaults.

Changing component to hunspell.

Core was generated by `hunspell -a'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000038fe27f312 in __strlen_sse2 () from /lib64/libc.so.6

Thread 1 (Thread 14530):
#0  0x00000038fe27f312 in __strlen_sse2 () from /lib64/libc.so.6
No symbol table info available.
#1  0x000000000040267e in add (
    dest=0x217e340 ".::/usr/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts:", st=0x0) at hunspell.cxx:1309
No locals.
#2  0x0000000000405978 in main (argc=2, argv=<value optimized out>)
    at hunspell.cxx:1589
        buf = '\000' <repeats 3768 times>"\214, \351\340\375\070", '\000' <repeats 11 times>, "i\b`\376\070\000\000\000\350\351\312\016r\177\000\000\322z\340\375\070", '\000' <repeats 35 times>"\322, \r\313\016r\177\000\000\001", '\000' <repeats 191 times>"\214, \351\340\375\070", '\000' <repeats 11 times>"\201, \034\300\b9\000\000\000\310\344\312\016r\177\000\000\322z\340\375\070", '\000' <repeats 35 times>"\322, \r\313\016r\177\000\000\001", '\000' <repeats 143 times>"\214, \351\340\375\070", '\000' <repeats 11 times>"\314, [!\376\070\000\000\000\000\340\312\016r\177\000\000\322z\340\375\070", '\000' <repeats 43 times>, "\001", '\000' <repeats 191 times>"\214, \351\340\375\070", '\000' <repeats 11 times>"\310, \r\313\016r\177\000\000\270y\034\017r\177\000\000\322z\340\375\070", '\000' <repeats 35 times>"\322, \r\313\016r\177\000\000"...
        pMS = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}
        key = 0x0
        argstate = 35115008
        arg_files = <value optimized out>
        format = 0
        dicplus = <value optimized out>
        aff = <value optimized out>
        dic = <value optimized out>

Comment 3 Caolan McNamara 2009-12-08 14:10:57 UTC
My guess here is that when run inside squirrelmail that there's no $HOME and that's the problem. Let me make a spin to survive that, and let me know if it works when you get the testing-update available update in this bug

Comment 4 Fedora Update System 2009-12-08 14:16:59 UTC
hunspell-1.2.8-13.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hunspell-1.2.8-13.fc12

Comment 5 Kevin Fenzi 2009-12-08 19:11:46 UTC
Works here too. 
Thanks!

Comment 6 Fedora Update System 2009-12-10 04:27:44 UTC
hunspell-1.2.8-13.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.