Bug 544413 - Creating a content provider results in multiple syncs being scheduled
Summary: Creating a content provider results in multiple syncs being scheduled
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: RHQ Project
Classification: Other
Component: Content
Version: unspecified
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: Jay Dobies
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-04 20:17 UTC by Jay Dobies
Modified: 2010-03-26 12:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-26 12:35:56 UTC


Attachments (Terms of Use)

Description Jay Dobies 2009-12-04 20:17:39 UTC
Description of problem:
Creating a content provider results in multiple syncs being scheduled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a new content provider
2. View log
  
Actual results:
2009-12-04 15:11:31,243 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentServerPluginContainer] Scheduled content provider sync job [535b7d6e--dead438--1255b519627:syncContentSource] to fire now at [Fri Dec 04 15:11:31 GMT-05:00 2009] for [ContentSource: id=[10011], name=[RPM Disk]]
2009-12-04 15:11:31,253 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentServerPluginContainer] Scheduled content provider sync job [535b7d6e--dead438--1255b519632:syncContentSource] to fire now at [Fri Dec 04 15:11:31 GMT-05:00 2009] for [ContentSource: id=[10011], name=[RPM Disk]]
2009-12-04 15:11:31,284 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentServerPluginContainer] Scheduled content provider sync job [535b7d6e--dead438--1255b51964a:syncContentSource] to fire now at [Fri Dec 04 15:11:31 GMT-05:00 2009] for [ContentSource: id=[10011], name=[RPM Disk]]
2009-12-04 15:11:31,290 INFO  [org.rhq.enterprise.server.plugin.pc.content.sync.RepoSourceSynchronizer] importRepos: [RPM Disk]: report has been merged (192)ms
2009-12-04 15:11:31,364 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentProviderManager] Content provider [RPM Disk] is already currently being synchronized, this sync request will be ignored
2009-12-04 15:11:31,364 INFO  [org.rhq.enterprise.server.scheduler.jobs.ContentProviderSyncJob] Content source [RPM Disk] is currently being synchronized already. Please wait for the current sync job to finish.
2009-12-04 15:11:31,366 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentProviderManager] Content provider [RPM Disk] is already currently being synchronized, this sync request will be ignored
2009-12-04 15:11:31,366 INFO  [org.rhq.enterprise.server.scheduler.jobs.ContentProviderSyncJob] Content source [RPM Disk] is currently being synchronized already. Please wait for the current sync job to finish.
2009-12-04 15:11:31,375 INFO  [org.rhq.enterprise.server.plugin.pc.content.ContentProviderManager] Content provider [RPM Disk] is already currently being synchronized, this sync request will be ignored
2009-12-04 15:11:31,375 INFO  [org.rhq.enterprise.server.scheduler.jobs.ContentProviderSyncJob] Content source [RPM Disk] is currently being synchronized already. Please wait for the current sync job to finish.


Expected results:
There should only be one scheduled. Perhaps two, if we schedule an immediate run and then the first in the repeating schedule, but even that is probably unnecessary.


Additional info:

Comment 1 Jay Dobies 2010-02-08 20:45:54 UTC
I just checked this and it no longer seems to be an issue.

Comment 2 Corey Welton 2010-03-26 12:35:56 UTC
QA Closing.


Note You need to log in before you can comment on or make changes to this bug.